Results 1 to 2 of 2
  1. #1

    Strange Layer shift problem

    Hey everyone,

    i am currently modding my twotrees sapphire pro for speed but im expiriencing bad layer shifts.

    I have actually watched it happen and it looked very strange.
    The printer was doing a top infill so going back and forth all the time. When it got near the end it suddenly did not go back and forth all the way but started to do the same infill move it was doing before just very small.
    It was doing the infill but on a 2mm square and not the whole part.
    After the printer finished the infill, it traveled to the next layer and kept going like nothing happened - but on the wrong location after losing the correct one in the strange 2 mm infill.
    It looked like it got stuck on something, but there wasn’t anything.
    Also i tried holding the printhead while it was printing with my hands and i wasn’t able to get the belts to slip, so in my opinion the motors and belt should not be losing steps.
    It also did not sound like Belts slipping.
    So maybe its software?
    It also seems to happen randomly, it will start and also finish some prints just fine and then start shifting layers.
    Maybe any of you know what could cause this kind of layershifting, or have some suggestions what I can do to find the cause of the problem.

    Printer Info:
    Two trees sapphire Pro
    e3d volcano hotend
    stock stepper motors
    tmc 2208 stepper drivers – 1,5 amps drive current
    Klipper on a Raspberrypi 4 with 2 gb ram - connectet via usb to the printer
    speeds - 110 mm/s
    travel - 150 mm/s
    acceleration 4000 mm/s*s

    I have just tried to print the same model just slower at 70 mm/s and it layershiftet again at a different layer.
    The printer printet just fine at 70mm/ before i switched to klipper and the raspberry.
    So i guess its also not a speed problem if slowing down doesnt help?
    Attached Images Attached Images
    Last edited by Alex13; 03-11-2024 at 12:25 PM.

  2. #2
    So, for anyone also experiencing this issue i found the problem.It was the TMC2208 stepper drivers overheating. I noticed when opining the electronics that the small fan blowing over the stepper drivers had died. getting the fan for cooling the Stepper drivers up and running again fixed my issue.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts