Results 1 to 8 of 8
  1. #1

    ender 3 v2 neo start up screen frozen

    I am really at wits ends. I just received a new ender v2 neo yesterday. I was able to print a few prints but now it is locked up on the creality start up screen. I have searched for issues and found potential problems with the thermister wires at the nozzle or the firmware. I have checked and can not find anything wrong with the thermister wiring. I have downloaded the latest firmware and installed it onto a memory card but when I try and install it when I start up the printer it will not install the firmware. I dont know what to do with this thing. Any advise what I can do?

  2. #2
    Problem solved, I didnt have the proper boot files installed. Still not sure why it has locked up twice for no reason.

  3. #3
    can you jjoos99 give us more update on this printer after you had tested it, since I may buy one soon.
    Last edited by Bikeracer2020; 01-24-2023 at 12:08 PM. Reason: link check

  4. #4
    out of the box it assembled easily. I had to adjust a couple of the rollers for being too tight and causing the print head to not move smoothly. Each time I made an adjustment to the roller at the head itself I must have done something to lock up the boot sequence. I had to download the newest firmware and restart the printer from the boot memory stick with the new firmware. Since then it has pretty much run perfectly. Been running it for about 3 days working on projects for my fish tank business and it has worked well. I am getting some stringing issues if I run more then one part when the head moves from one part to the next. My other big fight was at first I adjusted the printed head too close to the bed and it was spearing the filament instead of a nice string. It printed ok but I pretty much ruined my print table surface scraping off the melted pla. After getting the offset adjusted properly it is printing a very nice part. I am using petg as I need my end product to be totally water resistant. I have been quite impressed. The print looks just as good as the prusa that is used at the store I work at part time. The auto bed leveling is a must have in my opinion. After the initial fits and frustration I am very happy with it.

  5. #5
    Quote Originally Posted by jjoos99 View Post
    Problem solved, I didnt have the proper boot files installed. Still not sure why it has locked up twice for no reason.Jeff
    Hey Jeff, so I just got a new V2 Neo myself. I was able to print once, and now I am having the same issue, no firmware is working. What boot files did you use, please?

  6. #6
    I don’t have my computer that the file is on but I found it on crealitys site. Important thing is that the file is the only thing on your memory card. Once installed remove the file to use the card for normal prints.

  7. #7
    I tried all the files on the download page, but if finnaly it worked on my last attempt
    Thanks for the help!

  8. #8
    Hello Which files you used?I'm having the same issue.Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts