Hi there everyone,

I am new to all of this, so I hope you guys do not mind helping me out with this little problem I am facing. I am not really super experienced with all of this, I only started 3D printing about a month ago.

Yesterday I purchased a Tevo Tornado that had a heating problem. Before I went and bought it, I did some research on what it could be to determine if it would be a worthwhile buy and that I would not be wasting my money.

So about the printer.
Its a Tevo Tornado... obviously lol. Its got a MKS Base V1.4 motherboard. Its got BLTouch installed and the extruder is an E3D V6. And is running Marlin.

So when the printer is plugged in and starts up, the nozzle immediately starts heating up, Even though Autotemp is switched off. The thing is that it does not stop heating up at all, it keeps heating to what seems to be its maximum temperature the little heater can allow, which is 300 degrees. Once it reaches this, it stays there constantly, you can even try and start a print with a temp well below that and it does not budge on the temp at all.

So my first thought would be that it would be the thermistor ( The part that heats the nozzle), but the seller replaced it with a brand new one and it still gave the exact same problem. I also checked the temp sensor, as I thought maybe its faulty and not telling the motherboard that it is getting to hot, but it picks up the temp and shows it on the LCD and pronterface.

So from the research that I did, it said that it could need PID tuning, but it constantly fails when I try it. It also said that a low ESR capacitor might be needed, so I bought one since it was not to expensive.

So I tried for a few hours trying to get the PID tuning to work but nothing. I also tried to do some extra research, trying to find what it could possibly be. But I eventually gave up and tried to tackle the wiring situation... it was horrendous, so many exposed connections just hanging around. So I stayed up till 4 ensuring the wiring was on spec and rewired it according to a YouTube tutorial and the pictures I took when dismantling.

Today, I woke up with an idea that it could possible be a short that is causing the thermistor to be receiving max current at all times. So I swapped the wires for the thermistor and the fan. This would still allow me to control if the thermistor got power and when it did not. It worked. When the fan was switched off, the temperature stayed at room temp and did not rise at all, until I switched the fan on. So it looks like the E0 port that the wires connected to is shorted and nothing else it seems.

So since the motherboard is able to take another extruder I thought I would be able to just use the E1 port instead, but situation I am facing now is that I cannot find a way to change the E0 pin to the E1 pin instead. I have looked at quite a bit of different Marlin firmware versions that I could use but I have like zero knowledge on what I should be changing exactly. My train of thought was to change the pin values of both ports around but I would not even know where to start looking.

I apologize for all the additional information, but I wanted to give as much info to ensure there is a good understanding and to see my train of thought. If anyone is able to help me I would very much appreciate it, also if I am in the wrong place to post this please feel free to let me know where to post this.