Results 1 to 4 of 4
  1. #1

    Ender 5 Pro, DD added issues with extrusion, heylp

    So my E5Pro was working well, no issues with adhesion, decent prints on PLA, but I wanted to use TPU which I tried but loads of stringing etc.So I decided to get a direct drive avove the Hotend to help with retraction and stringing.Fitted the kit and changed the Esteps from 93 to 130 as stated, however the extrusion is really poor.So I removed the Hotend heated up and requested 100mm (using Mattercontrol). But only got 35mm ish, so have increased the Esteps to 450 approximately which now extrude 100mm when asked. However I don't think this is correct.The DD extruder extension cable swaps the 4 stepper motor to reverse so R, B, W, Bl to Bl, W, B, R which shouldn't cause issues but I think this cable or a faulty stepper is the cause (stepper wasn't faulty up until the DD was fitted.The change in Esteps from 93 to 130 was to compensate for the smaller extruder gear, did the math and 130 should be correctl but isn't hence 450 ish.Any historic advise or knowledge on this would be great.One other point there was a note to change - #define INVERT_EO_DIR to false, but the cable should do this and I don't know how to make this change.Any help appreciated.
    Last edited by Broughski; 09-19-2021 at 12:27 PM.

  2. #2
    Update - So I was really confused as to how/why when the kit said change Esteps from the standard 93 to 130/146 (Depending where you read) but in reality after changing to 130 and requesting 100mm - the measurements were way off.I had to change Esteps to 354 to actually get 100mm when requested, so as nobody answered my initial question I spent a good few hours trying to get more info, so have checked the coils in the Stepper (4 wire) and have 2+2 nothing more nothing less.I then removed the stepper extension/rewire lead and plugged my original cable and it does exactly the same as with the extension cable.I have retuned to 93 Esteps and this is also giving no where near 100mm when requested.So have I suddenly gained a faulty stepper motor or has the FW gone out of kilter.Does anyone know how to check a stepper motor? if so please help - at time of writing this update over 60 people have viewed this thread but sadly no replies.Thanks in advance.

  3. #3


    So, I tried a few more things to check/double check.In the end I have my Esteps back in the 354 range.The issue turned out to be the hot end, a crappy Swiss mk9 even, this is now back in its bag in the spares box.Creality hot end on the DD and it is working great after a bit of levelling, it is possible that the fan cowl was cooling the SGmk9 down too much but like they say if it ain't broke....So thanks, I'm mean really thanks to the 240+ who read my post and didn't have an opinion, I got help from a 3d printing section on drone forum of all places.

  4. #4
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014

    first time I've seen the thread.
    But as you gave no information on what kit you'd used, how you'd done the conversion or anything useful.

    Only people who'd done the same conversion would have had any idea anyway.

    so no need to get arsy with the forum :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts