Results 1 to 2 of 2
  1. #1

    Weird layer shifting

    I have an extremely consistent layer shift issue happening. This is an i3 clone that i've modified myself.
    This is the first time i've ever seen this happen. The printer is 3 years old.

    The Y axis shifts over about 0.5-0.7mm after completing layer 3, and shifts back the same distance when the print job is 3 layers from the top layer.
    It doesn't matter what the height of the cube is or where on the bed it's printed, and it doesn't occur anywhere else in the print.
    However, if I change the thickness of the bottom and top layers, the location of the shift changes as well. Like if I make it 5 layers then it occurs after the 5th layer and then 5 layers before the top.

    I've tried this with a 10mm x 10mm shape that's 10mm tall, 20mm tall, and even 100mm tall and it occurs regardless of the model's height.
    Rotating the model doesn't solve the problem, nor does using a different model altogether. I've also tried enabling z-hopping, slowed down printing speed, changed the infill density, and ran the command M502 just in case.

    This is an extremely consistent issue, occurred the exact same way on 10 different attempts, so I don't believe this is a hardware problem with the printer, because a slipping axis or a motor or driver issue would be occurring randomly.

    What's even stranger is last night this didn't occur at all and I was able to get five successful test cubes and one successful print job.
    I did change the filament from white Hatchbox to black Hatchbox, but I have no idea how the filament could make a difference.
    The only difference between the filament is the white filament was pulled out of the box brand new, while the black filament is over a year old and spent a day in my filament dryer after I determined it absorbed too much moisture.

    Some data on the printer:
    - i3 clone, heavily modded Geeetech i3W
    - DRV8825 stepper drivers
    - BLTouch leveling sensor
    - Glass print surface
    - Repetier Host / Cura used as slicer
    - Printer is 3 years old

    I've attached the gcode file from the most recent print job that showed this issue.
    I've also attached a photo of the most recent test, showing the shifting.
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by novarlynx; 08-17-2020 at 09:42 PM. Reason: Line breaks got removed somehow, making the post a wall of text.

  2. #2
    I would say that DRV8825 are to blame.
    Change them to A4988 (cheap, reliable), LV8729 (silent, cheap) or TMC2209 (advanced, silent).

    It would also be possible that there is a mechanical issue with linear drive, be it either belt, bearings or pulleys.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts