Results 1 to 3 of 3
  1. #1

    Ultimaker original x-axis not moving - possible electronics problem

    I'm writing this Question here hoping someone will be able to help me with the fixing process that I'm currently involved in!
    Last week during a printing session my Ultimaker original unexpectedly stop working. The problem was on the extruder step motor which push the filament from the back and literally is not moving anymore! The first thing I have done was to check if the motor was burn or something similar. So I swap the extruder motor with the x axes one and it then worked fine.
    Then later the x-axes motor into the extruder connector and is not moving! so I decided to check the step driver and they seems to work all well. So the problem must be on the Arduino or on the motherboard! I bought new step driver a new step motor and new Arduino + motherboard, connected all up and nothing, still not working for the same reason! Is just the extruder motor that won't work anymore!
    Do you guys have some idea or tips to find out what the problem can be or how can be fixed in alternative ways? Your help will be much appreciated and looking forward for some answers.
    Thanks a lot, Riccardo

  2. #2
    Staff Engineer
    Join Date
    Jul 2016
    South Florida, USA
    Add AutoWiz on Facebook
    I have a couple thoughts about this. First and most importantly if your board supports 5 stepper motor drivers then why not move the extruder to the open driver port on the board? Alternatively you could consider upgrading to an all in one control solution like the gt2560 here:
    Or this megatronics v3.0 board here:
    Both of these board run the same marlin firmware you are currently running. Both have extra stepper motor driver mounts for either expansion or attrition tolerance, lol.

    As far as pinpointing your problem, First I think I would try a simple wiggle test. command the stepper motor to move and wiggle the wires going to it at the mainboard and at the stepper motor. verify there is not a connection problem. if the stepper motor turns on and off as you wiggle the wires, then plug the motor into another port on the mainboard and repeat the test and see if the failure follows the stepper motor or stays on that one port with different motors. if the latter is the case, then you might have a failed solder joint on the board. Past that a good way to pinpoint a failure here is to swap the motor with a different axis, swap the driver with yet another different axis, and see where the problem, goes. if it stays it is a problem with the board, if it goes with the stepper it is a failure with the stepper and if it goes with the driver then you burned up the driver board which is the most common failure I think.

  3. #3
    thank you soo much for replying and I will definitely try all your suggestions and be back asap.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts