Close



Results 1 to 2 of 2
  1. #1

    Auto Leveling Problem

    I'm having problems getting my printer to auto level correctly. It has a probe auto level feature that seems to run just fine but no matter how many times I use it, my first layer is still messed up. After auto leveling and adjusting my Z offset it still prints uneven. From the first layer it appears that the print head is closer to the bed surface on one side vs the other. Isn't the auto leveling supposed to compensate in the Z during for the uneven surface?A couple strange things I noticed from the outputs below:1: My filament is set (default) to 3.00mm in the firmware and I'm printing 1.75mm with no extrusion problems from what I can tell. Once I change it to 1.75 it does not extrude at all once it begins printing. 2: After M420 it says that bed leveling and fade height are off but it appears to run through the bed leveling process with no issues.

    What mechanical problem could be causing this? Is it worth considering a firmware upgrade/how hard is that to do?

    Printer/Firmware Info:
    Printer: FLSUN QQ
    Firmware: Marlin 1.1.6

    Send: M503
    Recv: echo: G21 ; Units in mm
    Recv: echo: M149 C ; Units in Celsius
    Recv:
    Recv: echo:Filament settings:
    Recv: echo: M200 D1.75
    Recv: echo:Steps per unit:
    Recv: echo: M92 X100.00 Y100.00 Z100.00 E90.00
    Recv: echo:Maximum feedrates (units/s):
    Recv: echo: M203 X500.00 Y500.00 Z500.00 E25.00
    Recv: echo:Maximum Acceleration (units/s2):
    Recv: echo: M201 X3000 Y3000 Z3000 E5000
    Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv: echo: M204 P1500.00 R1500.00 T1500.00
    Recv: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv: echo: M205 S0.00 T0.00 B20000 X10.00 Y10.00 Z10.00 E5.00
    Recv: echo:Auto Bed Leveling:
    Recv: echo: M420 S0 Z0.00
    Recv: echo:Endstop adjustment:
    Recv: echo: M666 X-0.49 Y-0.04 Z0.00
    Recv: echo: Delta settings: L<diagonal_rod> R<radius> H<height> S<segments_per_s> B<calibration radius> XYZ<tower angle corrections>
    Recv: echo: M665 L280.00 R141.61 H386.29 S160.00 B90.00 X-0.32 Y0.83 Z-0.51
    Recv: echo:Material heatup parameters:
    Recv: echo: M145 S0 H180 B70 F255
    Recv: M145 S1 H240 B100 F255
    Recv: echo:PID settings:
    Recv: echo: M301 P22.20 I1.08 D114.00
    Recv: echo:Z-Probe Offset (mm):
    Recv: echo: M851 Z-2.10
    Recv: ok


    Send: M115
    Recv: FIRMWARE_NAME:Marlin 1.1.6 (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:FLSUN EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv: Cap:EEPROM:1
    Recv: Cap:AUTOREPORT_TEMP:1
    Recv: Cap:PROGRESS:0
    Recv: Cap:PRINT_JOB:1
    Recv: Cap:AUTOLEVEL:1
    Recv: Cap:Z_PROBE:1
    Recv: Cap:LEVELING_DATA:1
    Recv: Cap:SOFTWARE_POWER:1
    Recv: Cap:TOGGLE_LIGHTS:0
    Recv: Cap:CASE_LIGHT_BRIGHTNESS:0
    Recv: Cap:EMERGENCY_PARSER:0
    Recv: ok
    Send: M155 S2
    Recv: ok



    Send: M420
    Recv: echo:Bed Leveling Off
    Recv: echo:Fade Height Off
    Recv: ok

  2. #2
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Location
    Washington State, USA
    Posts
    784
    Add Roberts_Clif on Thingiverse
    When first learning 3D Printing though was using auto leveling but later found out I was not.

    In order to use the auto leveling on my 1st 3D Printer I had to add M420 to the end of my slicer G-Code. Then was printing with the auto leveling on.
    I would select the auto bed leveling form LCD
    I would save the Data using Store Settings or M500
    The in the Startup G-Code world restore Bed Leveling Data M420 S1 see My Cura Startup G-Code below

    Code:
    ;Filament used: {filament_amount}m {filament_weight}g
    ;Filament cost: {filament_cost}
    ;M104 S[first_layer_temperature] ; set extruder temp
    ;M109 S[first_layer_temperature] ; wait for extruder temp
    ;M140 S[first_layer_bed_temperature] ; set bed temp
    ;M190 S[first_layer_bed_temperature] ; wait for bed temp
    G21        ;metric values
    G90        ;absolute positioning
    M82        ;set extruder to absolute mode
    ;M106 S127 ;set Fan half speed
    M107       ;start with the fan off
    G28 X0 Y0  ;move X/Y to min endstops
    G28 Z0     ;move Z to min endstops
    G1 Z15.0 F{travel_speed} ;move the platform down 15mm
    ;Put printing message on LCD screen
    M117 My Print...
    G28 X0 Y0
    G1 E4.0 ;prime extruder
    G92 E0 ;reset extruder length
    M420 S1   ; Bed Leveling On

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •