Close



Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Ender 3 Not Extruding

    I have a problem with my extruder and don't know where to turn. It has been sporadically stopping extruding partway through a print for a couple weeks. If I restarted the printer it would behave fine for a print or two and then do it again. Now it won't extrude at all. It's not a plugged nozzle, I can push filament through it fine. The printer has been upgraded with a SKR 1.3 board with TMC2208 stepper drivers. It has Marlin firmware. I have swapped the stepper driver and the motor still won't turn. I then plugged the motor into the X axis connector and it turns fine. The firmware hasn't changed for a few months. I don't know what to do next short of putting the original board back in it. I changed it in the first place so I could print with PETG so I really don't want to do that.

  2. #2
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Location
    Washington State, USA
    Posts
    758
    Add Roberts_Clif on Thingiverse
    I would check the alignment of the Extruder Gear. Could be catching of the extruder assembly.

  3. #3
    Quote Originally Posted by Roberts_Clif View Post
    I would check the alignment of the Extruder Gear. Could be catching of the extruder assembly.
    It's not that. I have it removed from the mount and the gear is off. Doesn't run when requested to.

  4. #4
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Location
    Washington State, USA
    Posts
    758
    Add Roberts_Clif on Thingiverse
    A point about Marlin firmware .
    FYI - Marlin has a safety it the hot-end is not up to 170C it will not turn.

    Code:
    #define PREVENT_COLD_EXTRUSION
    #define EXTRUDE_MINTEMP 170

  5. #5
    Quote Originally Posted by Roberts_Clif View Post
    A point about Marlin firmware .FYI - Marlin has a safety it the hot-end is not up to 170C it will not turn.
    Code:
    #define PREVENT_COLD_EXTRUSION#define EXTRUDE_MINTEMP 170
    I have the hot end heated up while I'm troubleshooting it.

  6. #6
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Location
    Washington State, USA
    Posts
    758
    Add Roberts_Clif on Thingiverse
    Then I would suggest that the stepper motor cable could be intermittent an may need testing / replacing

  7. #7
    Quote Originally Posted by Roberts_Clif View Post
    Then I would suggest that the stepper motor cable could be intermittent an may need testing / replacing
    Yeah, I'm going to order a new cable and start from there. Thanks.

  8. #8
    I'm pulling my hair out now. This problem has a mind of it's own and I can't pin it down to anything specific. I have swapped cables, motors and stepper drivers and it seems to work for a bit with each trial and then it goes back to not moving again. The last time it did it the motor spun for a revolution or 2 and then shuddered for a second and then stopped. I ordered a replacement motor and cable (came together) with the hopes that it would be one or the other and when I hooked them up it did the same thing. So now all I have left is to try updating and re-flashing the Marlin firmware and if that doesn't do it I guess I will have to replace the mainboard. This mainboard is only 4 months old. I don't know if they'll replace it for me or not.

  9. #9
    Engineer-in-Training
    Join Date
    May 2018
    Posts
    377
    I am very confused, why do you need to upgrade a main board to print PETG? There is virtually nothing different between printing PETG and PLA but maybe 20 degrees.. PETG prints best for me at 230C, PLA 210-215C Please explain why you had to upgrade the printer for it to do something so basic as heat the hot end to 230C.

  10. #10
    Quote Originally Posted by airscapes View Post
    I am very confused, why do you need to upgrade a main board to print PETG? There is virtually nothing different between printing PETG and PLA but maybe 20 degrees.. PETG prints best for me at 230C, PLA 210-215C Please explain why you had to upgrade the printer for it to do something so basic as heat the hot end to 230C.
    Actually the main reason I upgraded the board was to quiet down the printer. It made a huge difference in that respect. I misspoke on the PETG part.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •