Results 1 to 7 of 7
  1. #1

    initial success...then failure

    hi - first post here - just so everyone understands - i am retired and in my 60's - i am brand new to 3d printing - my family bought me one for my birthday in december - they know i like to tinker and make stuff and i was very happy to receive this gift - while i consider myself semi tech savvy i don't know how to write code - usually i "play" with a program and gradually get used to it's particular quirks - so i assembled this reprapguru 3d printer in early january - the reprapguru website has downloads for arduino and repetier, which i installed and got the printer to answer commands as far as moving the extruder head in all directions - i then started with sketchup and designed a fitting for my shop vac - had a lot of problems as it's a open tube but the slicer (repetier came with cura engine and slic3r) - they both wanted to put in solid layers at certain levels of the tube - so i printed out a couple of them and cut out the 2 layers (after much setting work i got the solid pieces down to 2 and figured that's as good as i could do right now) - the pieces work great but i thought i'd look for another slicer to see if i could get rid of those 2 layers - i downloaded cura 3 (i think that's what it was) and installed it - the printer has not worked since - i uninstalled cura 3, but it still won't print right with either slic3r or cura engine - so i uninstalled repetier - since i had changed so many settings in it's 2 slicers i figured i'd start over - i ran the initial arduino setup but still can't get it to print correctly - the extruder starts printing in the air about 2-3 mm above the plate and now it's having thermal runaway 0 (which i believe is the plate...right?) issues - i've spent the better part of 4 days working on this to no improvement - some questions
    1) does running the arduino initial upload again erase the previous install and start fresh...

    2) if not how do i completely reset the board as new....

    3) why the "air" printing? after it worked great initially (i have slightly tried to tweek the g code but honestly i don't know what i'm doing) - i tried changing some of the z coordinates but then the printer would only print the first layer over and over....

    4) could all of this be because of the cura 3 install?...-

    5) why after it working would it now have thermal issues - i watch the temps as it's printing and they don't seem to skew off the set temp more than a degree

    any help appreciated - thanks in advance
    Last edited by honerboys; 02-18-2019 at 04:21 PM.

  2. #2
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    aarghh - for gods sake find and USE the return key !

    Okay I will wade though the mass of text....

    It's a cheap i3 - pretty much an anet a8 clone.

    Have you tried a system restore on your computer to a point just before you initially installed the printer ?
    That would be my first move. Even macs can do a system restore - yes really, crap as they are :-)
    Be careful if you have windows 10 as it prefers to wipe everything, rather than a simple system restore.
    As I refuse to have a windows 10 computer in my workshop - unless it's someone elses ;-) - can't, off the top of my head tell you the system restore procedure.
    A search should find lots of videos and articles on it though.

    second - sketch up is not great for producing the solid models 3d printing needs.

    have a look at openscad:
    Have a look round for some basic tutorials - much easier to use than you originally think :-)

    Sounds like either the slicer was adding a solid diaphragm at cwertain levels, or sketchup just bogged the stl up.

  3. #3
    how's that? - i really just started rambling there didn't i? - sorry - i don't want to do a restore on this windows 10 machine - i installed the printer in early january and that's a lot of time - it took so long to get it set up like i want it and i know a restore will mess it up somewhere - but if i have to i will - i did try to get rid of all the registry entries but...? - how about questions 1 and 2 ?..although i'm pretty sure the problem is in the repetier / slicer area as i can see in print preview the object is 2-3 mm above the printer plate after slicing but in the placement window it's flat on the deck

  4. #4
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Washington State, USA
    Add Roberts_Clif on Thingiverse
    Hello honerboys;

    I like using ThinkerCad it is an online program that is simple to use.
    I also use Fusion 360 Freethough is has a steep learning curve there are many You-tube videos too teach you all you need to know.
    When I first started using my 3D Printer while experimenting with all the different slicers, I too ran into this problem.
    As some slicers send G-Code that allows them to change the 3D Printers settings to work better, though only if you have setup the slicer correctly for you 3D Printer.
    Otherwise it will send G-Code that will cause your 3D Printer to incorrectly function.
    Hours later found that all that was needed was for me to factory reset the 3D Printer.

    Using Cura 15.04.6 I sent G-Code to the 3D Printer to restore the factory defaults, and all was well again until I again did the same and had to reset 3D Printer again.

    M502 - Factory Reset
    M500 - Save Settings
    Last edited by Roberts_Clif; 02-22-2019 at 03:00 PM.

  5. #5
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Slicer wise I use simplify3d and flashprint.
    old style cura up to 15, wasn't totally awful, the new one is horrible. haven't looked at slic3r for a few years, but it has to be more user friendly that cura.

    It is annoying that you have to have repetier to control the printer. simplify3d has a built in control panel that does everything repetier does.
    Why cura and slic3r don't add a printer control panel - I don't know.

    All a restore does is remove programs. doesn't mess with programs that existed before the restore point or any of your files.

    If you've flashed the firmware, then the only way to put it bacl is to flash with the original firmware.
    I tend to leave my firnware alone, I suspect this is why I've never had any issues with it on any of my machines :-)

    The arduino is simply the driver software and what you use to flash the firmware (you mean ide right ?).
    Have you checked the com port for the printer - that might have changed.

    The z-height thing might just need re-calibrating.
    Or you could have changed it :-)

  6. #6
    thanks for the replies - when the printer arrived i uploaded the firmware through arduino IDE - so i've done that 2 more times - i was thinking maybe something went wrong in there - but i assume when i uploaded it again it completely removed and replaced it with a fresh copy - the extruder will home to the correct coordinates and is a paper thickness from bed - just starts 2mm off when printing - ill' download simplify3d, flashprint, thinkercad, and fusion360 and check them out - i'm only using repetier and slic3r/cura engine because that's what came with the printer - i am going to check all wiring and connections - thanks again for your help

  7. #7
    hey - thanks for all the suggestions - i looked at the wiring to the heater/ thermistor - i put an ohmmeter on the thermistor where it connects to the board while moving the bed back and forth - the resistance did jump a little bit (1-3 ohms) - it seems those wires crossed directly over the led on the plate - while i didn't see any open wires on the thermistor leads if i moved them right where they went over that led the resistance would change - i moved those wires an inch off the led and re-taped - the jumping of the resistance stopped - as i said i went through and removed all programs and registry entries in windows - so i reloaded a newer version of repetier/slic3r and tried a sample print of a cube - it did print correctly but rough - i tweeked some slicer and printer settings (this time i saved the original setting though) - the result is that it prints as good as it did before all these problems - so i'm back up and running - i'm going to try some of the programs suggested here and see if they work better than the sketchup/repetier/slic3r combination i'm using now - i've run into this before ..where windows "remembers" something in the registry and screws things up, especially when i repeatedly install and remove a program - hopefully it's all good now - thanks for all the advice

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts