Hello everyone.

I changed my bed on my Sidewinder X1, which I upgraded with an MKS GEN L V2.1 and TMC2209s long ago which works fine.

But since I changed the bed, (only) the Y-axis homes in the wrong direction.

Movement is in the correct direction from OCTO and the LCD. When I turn the printer on and go directly to the move screen before homing, I can only move the printer towards the end stop (YMIN), and after that, I can only go back away from the YMIN as far as I went towards it (software end stop I presume).

No change was made in the plugs or wiring of the motor or end stop.

To troubleshoot, I tried reverting back to the previous bed (yep.). I also tried compiling a new updated version of Marlin. I also tried a different motor and a different end stop. None of these worked.

M119 reports correctly for all end stops.

There is no interference on the cables, as they are the original cables from the sidewinder and I have also tried different shielded cables.

The same happens even if disconnect the end stop completely.

I am close to giving up as I have spent many hours researching and troubleshooting the issue, and now find myself here.

I really hope somone can help. Any more info required, let me know please.

Thank you