Results 1 to 2 of 2
  1. #1

    Ender 3 / 4.2.7 / Marlin 2.1.2 / EPROM not saving settings?

    Aloha everyone!
    I'm new here and hope for your expertise.
    Following problem: Almost immediately, my printer has the problem of printing "in the air".Really speak from the 1st layer.

    I'm using an Ender 3 with a 4.2.7 board and Marlin 2.1.2 installed. I've been using the part for almost 2 years (the board was added almost 1 year ago) and also use a PEI pressure plate from Creality.I level both manually in advance via springs (I exchanged the original ones for hard ones at the time) and then via the firmware via mesh bed leveling. Has always worked perfectly, great results and always great adhesion. It's been about 3 days now that suddenly everything is printed in the air. But not somehow..

    The first time I went there and thought to myself that this could be the case, maybe I had somehow adjusted the bed or something like that and leveled it up. Test print and a subsequent model -> flawless. Then the part was switched off at some point, switched on again and lo and behold, it prints in the air again.I then checked it again, i.e. leveling with subsequent pressure -> no problem. Turned off, turned on -> in the air.I then chose the path via the profiles with which something could possibly be wrong (use the profiles from Chep with Cura 5.2.1 as a basis) and first only deleted and renewed the profiles and after I found that there was something wrong with them not lag, completely reinstalled Cura. But always the same picture.Yesterday I then recompiled Marlin in the latest version. And again: Exactly the same pattern. Level, print, great. Printer turned off, turned on and it prints messed up again. So I assume that he somehow loses the settings (of course I always saved the settings after leveling and tried to load them, nada).

    The only thing I could think of would be a defective mainboard or the "internal memory"!? Is that possible or do you have another approach?EPROM btw. is enabled in Marlin 2.1.2

    Thanks in advance and greetings!
    Last edited by fowLakatah; 01-13-2023 at 01:12 PM. Reason: bad text formatting

  2. #2
    I was able to solve the problem with deactivating Babystepping in Marlin bevor compiling the firmware.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts