Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11

    Quote Originally Posted by macfelix View Post
    Sounds like the MAX6675 thermocouple amplifier chip is blown, probably from a short due to a frayed wire on the old thermocouple. I went through this very recently. I replaced the 8pin chip and was back up and running. If you are up for replacing surface mount chips I can show you what to do and where to get another chip cheap.
    Thank you!!!

    I've registered just to show my gratitude!

    I convinced my employer to buy a Qidi x-plus a few years ago and for six months or so it worked really well. Then, changing a worn nozzle I crimped the thermistor wire. Main board blown. Work were unwilling to buy a new one for various reasons (certainly not money though) and so eventually I brought it home and bought the board myself.

    Fast forward a couple of years and despite being very careful with the thermistor wires the same issue again. I tried all the same steps as the OP with the same result and was on the verge of ordering ANOTHER new board (which is a financial pain right now tbh) when I found this thread. Ordered two breakout boards from Amazon with the chip on, £8.65 with sub 12hr delivery. Replaced and I'm back in business!

    I guess a resettable fuse would affect the resistance and throw out the thermistor (I'm not an electronics engineer!) but it seems like a killer weak spot on the otherwise great Qidi printers.

    Thanks so much again, all the best!

  2. #12
    Hey that's great! Thanks for letting me know.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts