I have a Qidi X-Smart printer. It is not reading the temperature of the thermocouple on the hotend, or, rather, the software shows a temperature of 600+ degrees (fahrenheit) whether the thermocouple is connected or not.

Remedies I have tried so far:

1) Replace the theremocouple (first with a generic one from Amazon, then with an OEM replacement from Qidi). Result: No change
2) Replace the breakout PCB board to which the thermocouple connects. Result: No change
3) Re-seat the thermocouple in the hot end. Result: No change
4) Replace the ribbon cable that connects the breakout PCB to the main board. Result: No change
5) Software "factory reset". Result: No change

Prior to experiencing this problem I had a blockage of filament in the hot end. Once I remedied that the current problem started.

I took the printer to the local 3d printer repair shop. After a month they hadn't come up with a solution or even a diagnosis, so I took the printer back and tried replacing the parts listed above. I would think if the problem was something obvious, they would have figured it out quickly.

Any help or insight or hypothesis to be tested will be much appreciated.

All the best.