Close



Results 1 to 3 of 3
  1. #1
    Banned
    Join Date
    Mar 2021
    Posts
    62

    BIGTREETECH TFT43 Touch mode

    Hi.I installed a BIGTREETECH OCTOPUS V1.1 motherboard, BIGTREETECH TFT43 display, TMC2226 in the E5P. I have both modes on the display, Touch Mode and it reports No printer attached, and Marlin Mode reports 3D Printer Ready. I don't know how to run Touch mode. I am a beginner, so I still know everything.Thank you in advance for your help.

  2. #2
    Staff Engineer
    Join Date
    Jul 2016
    Location
    South Florida, USA
    Posts
    1,208
    Add AutoWiz on Facebook
    Hello. So in touch mode there is a delay in communications. The printer needs to be completely boosted up before it will communicate with the tft. Also I have noticed sometimes if I power on the printer in Marlin mode and then try to switch to touchscreen mode sometimes communications can be hit or miss. There are a few points we need to verify for proper communications with the tft..

    - First and foremost is the baud rate. This is the communication speed and it must be set in both the tft and the Marlin firmware. In the tft you should be able to walk through the menus and find the settings and the communication speed or baudrate setting. And in Marlin it will be at the very top of the configuration.h tab. Both of these numbers need to be 115200. The tft can not handle faster communications stably. And if the two numbers are different they are speaking in different languages and will never understand each other.

    - Next you need to check the serial port selection in Marlin under the configuration.h tab. Also at the top near the baudrate. Serial Port 1 is preset to 0 and should be changed to 1 and then I like to uncomment serial 2 and set it to -1.

    - Also you need to look at your wiring. Sometimes we get the RX and TX lines confused. And for good reason. RX is receive and TX is transmit. In practice a transmit pin is not going to read what another pin is trying to transmit. So TX from one should be wired to RX from another. However, sometimes we see tx going to tx and rx going to rx and communication works. The best way here is to try both ways. UNLESS you have a specific cable for the tft to connect to a specific board. Then you know you are good.

    Try these steps and see if you get the communications. Remember to have the screen in touchscreen mode before you power down so it powers on in that mode and give it 30 sec to 1 min from the time you power on for communications. It goes much faster with the Octopus I am just sugggesting patience until you see it actually function. But it should come on in 10-15sec I think with the 180mhz Octopus.

  3. #3
    Banned
    Join Date
    Mar 2021
    Posts
    62
    This is great, I had tx1 / tx2 and rx1 / rx2 set and that's why I didn't like it, it was enough to swap it and everything is functional. Thank you very much for your great help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •