Results 1 to 3 of 3
  1. #1

    USB communication issues with creality 32 bit v4.2.7 board

    Hello Everyone,

    I upgraded my Ender 3 Pro with the 32 bit board but I cant connect it to my PC. The device manager doesn't show anything. Otherwise the board is working fine.

    I tried the following:
    -various different cables-Laptop and 2 Tower PCs (all Win10)
    -installing the CH340 Drivers (i tryed the version from th3d and the one on the stock sd card)
    -new firmware (Marlin v2.0.x bugfix)
    -sacrificing a goat to the gods

    Since the only forum entries resembling my issue related to octoprint i thought the board was broken and ordered a new one but it has the same issue... (i have not installed the new one in the printer but the power from the usb cable should be enough to show in the device manager or not? It is with the old board anyways)

    Since the same issue occurs with multiple PCs and boards it has to be something stupid i am not aware of... Or does the new board require power from the main power supply to establish connection and my first board is actually broken??

    Thank you in advance.

    Last edited by Phill1337; 02-07-2021 at 06:13 AM. Reason: format buggy

  2. #2
    Never mind. The one board was actually broken and with the other i just tried the wrong cables

  3. #3
    I thought the board was faulty because the only forum comments that resembled my problem mentioned octoprint, so I got a new one, only to find that it has the same problem... If the power from the USB cable is sufficient, should I see it in Device Manager even though I haven't inserted the new one in the printer yet? In any case, it's with the old board.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts