Close



Results 1 to 4 of 4
  1. #1

    Question Problems with X axis movement. Help needed.

    i have been printing with no problems. I have finished the spool of filament and removed the remaining filament from the bowden tube and hotend. Before loading the new spool of filament, I decided to level the bed using the installed BL Touch.

    Probe grid 3 x 3. Centre point of the build plate, X:135, Y:130.

    Homed the bed (G28). Levelled the bed (G29). The first four probe points worked as expected. when the printhead moved to the fifth probe point, the screen read that the printhead was in the expected position (X:130, Y:130). The printhead had only moved about 20mm, meaning the true position was X:240, Y:130, I had checked this with a ruler. The sixth probe point also moved about 20mm on the X axis. The seventh point moved along the Y axis correctly. The printhead tried to move correctly to the eighth point and promptly crashed into the side of the printer as it was trying to move 130mm to the right. The screen had X:0 when in reality it was X:230.

    I tried the ABL again. This time I aborted the ABL on the fifth probe point as the previous event had been repeated. Reported position, X:130, Y:130. True position, X:240, Y:130. I then tried to home the bed (G28). The printhead moved a short distance to the left (<20mm) on the X axis, reported on screen that X:0 and started along the Y axis. When it had reached Y:0 (true position) it then moved diagonally to where it thought would be the centre of the bed, but would have crashed into the side of the printer frame if I had not cut the power.

    After re-setting the board, I could home the board either by using G28 or via the screen. I could move the printhead along the X axis freely, both through Pronterface and the printer screen. If I tried to home the printhead when X>140, it would only move a short distance to the left, set X:0 on the screen and head down the Y axis.

    I have checked for loose connections and everything seems tight. The only difference from when I was last able to print is there is no filament loaded.

    Anybody any ideas what is wrong?

    Printer: Hypercube Evolution (CoreXY)
    Board: KFB2.0
    Last edited by Ramblin' Sid Rumpo; 02-04-2021 at 10:57 PM.

  2. #2
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Posts
    8,834
    had you used the probe before and had it work ?
    Or is this the first time you'd tried it ?

  3. #3
    Probe had been used frequently. The only thing that was different from when I was last able to print is that then there was filament loaded and now there is no filament loaded. All hardware was working and there has been no change to Marlin 2.0.6.1.

  4. #4
    After many hours tinkering, pulling things apart, testing them and re-assembling them, it turned out that the problem was a broken wire for the X_Min endstop. This has now been replaced and the problem is resolved.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •