Results 1 to 4 of 4
  1. #1

    Question diy 3d printer problem

    i'm building this 3d printer using and Arduino mega 2560 and the Ramps1.4, plus the A4988 drivers.
    i've used marlin 1.1.x and followed youtube tutoriels to set it up, flashed it to my card and used pronterface to command it and here's where the problems occured, now my situation has two phases : what used to happen, and what is happening now so bear with me :
    - at first when i tried commanding the stepper motors the X and the Y motor would only vibrate and not move, the Z motor would move but not synchronized ( one would stop and the other one continues) and their rotation wasn't according to the command i would send (i would send a command to move 1mm and the would spin for like 40s at least one of them as the other one stops not so long before, and even the endstops wouldn't trigger them to stop eventhough i checked that the endstop were working using the command on pronterface). and sometimes even if would command the X or Y motors, the Z motors would start spining.
    the other problem at this phase was that the LCD was kindda showing some giberish writing and wasn't clear at all.
    ( i tried multiple modifications on the firmware, tried adjusting the potentiometre o the drivers, tried changing the cables, changing the orientation of the cables, switched between motors...ect but nothing seemed to work)
    - moving to what's happening now. now the screen in all bleu and blank, and none of the motors would work no matter what i would try, i retired everything i did the first time, i replugged all the cables multiple times to make sure that i'm not mistaken, i tried the test code for the stepper motors but without results, i even tried the repitier firmware but nothing worked, ( also i tried the graphic test for the screen but it didn't work)
    did this happen to anyone else, and can someone guide me to atleast test that the components are failling.

  2. #2
    Staff Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Washington State, USA
    Add Roberts_Clif on Thingiverse
    We can help you, if you can have Patience. This could be short or a long process.

    Lets start with more information than you have given us.
    Post a picture of your 3D Printer, post your Marlin 1.1.x configuration files.
    Measure your Stepper motor Vref current and post.
    You can measure the power supply voltage at the supply and at the controller, we may need to make further supply measurements after we proceed to ensure proper voltage while in operation.

    With this information we can get a basic ideal where we need to proceed to start helping you.
    While we look at this information you can help by making sure that all stepper motor Axis have a smooth and free travel without any binding.
    Make sure that the belts if any are snug with causing any binding and center any bearing without the belt rubbing on holders...

  3. #3
    thanx for your reply i've set the Vref on the drivers at 0.55V ( my steppers are 1.3A) . the voltage at the power supply and the ramps is 12.2V. the motors are not even fixed to the printer any more, i've set them free until i finish the tests
    Attached Files Attached Files

  4. #4
    Staff Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Washington State, USA
    Add Roberts_Clif on Thingiverse
    Noted your Vref current settings.
    This is Mine for both 12 v and 24 volt 3D Printer Systems.
    Hictop Axis Stock 12volt 24volt
    X-Axis 0.8 0.695 0.395
    Y-Axis 0.8 0.695 0.395
    Z-Axis Dual Stepper 1.0 1.396 0.710
    E0 0.8 0.695 0.395
    E1 0.8 0.695 0.395

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts