Close



Results 1 to 3 of 3
  1. #1

    Help with updating firmware

    (Let me just start off by saying I have very little experience with this type of thing so go easy on me) I have a CR-10s Pro and I cant seem to figure out how to update my firmware. Any tutorial i have watched either hasn't worked or is out of date. Could someone by chance give me some steps on how to do it? The reason I want to do this is because I bought a new sensor for my printer and it works but when I begin a print the nozzle goes down to detect the bed, up and then down again to detect the bed again like normal, but then the nozzle just dives into the bed and nearly breaks the nozzle. Also the nozzle goes off to the top left corner instead of the middle when beginning a print. I'm just assuming this is a firmware problem so I just wanted to try updating it to the normal firmware since the current firmware I have is the tinymachines one I believe? Please help!

  2. #2
    update: I fixed the issue where the nozzle runs into the bed by using different starting gcode with cura, but my printing origin is so far off from the center. Anyone know how to fix this?
    (I dont think this is an issue with cura since it goes to the same place (not the center) when i press "home" on the printer itself)

  3. #3
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Posts
    7,530
    switch to prusaslicer - cura sucks.

    basically the origin is set in the slicer. But as i don't use cura can't help on where to put your settings.

    I will say that on my i3 you set the origin to 0x0 and the slicer (in this case simplify3d) uses that and the bed size to start printing in the centre of the build plate.

    On my other printers the origin is set to the centre of the bed itself. But i3's seem to work differently :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •