Close



Results 1 to 4 of 4
  1. #1

    Auto home is homing off of the bed..help

    So I replaced my Ender 3 motherboard with a BIGTREETECH SKR Mini E3 V1.2.

    I had to compile new Marlin firmware and enable the bltouch. Before with my factory motherboard it would auto home to the center of the build plate. Now it tries to auto home off of the build plate at 0.

    With my bltouch I am using a smooth fang cooling duct with the bltouch mounted to the right of the print head. The offsets I used on the factory board were
    define X_PROBE_OFFSET_FROM_EXTRUDER 50
    define Y_PROBE_OFFSET_FROM_EXTRUDER -5

    With the new board I have to use #define NOZZLE_TO_PROBE_OFFSET { 50, -5, 0 }

    I think it is the -5 that is pushing it off the build plate but why is it even trying to auto home to 0 and not the middle of the build plate?

    How can I fix this in the firmware?

  2. #2
    I uncommented#define Z_SAFE_HOMING and now it is trying to go down and detect with the bltouch off of the bed on the back right corner instead of the front left. Any ideas?

  3. #3
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Location
    Washington State, USA
    Posts
    697
    Add Roberts_Clif on Thingiverse
    In Marlin there is Z-Safe Homing it does not set the nozzle in the center of the bed on my 3D Printer though it move it fairly close.


    #define Z_SAFE_HOMING

    #if ENABLED(Z_SAFE_HOMING)
    #define Z_SAFE_HOMING_X_POINT ((X_BED_SIZE) / 2) // X point for Z homing when homing all axes (G28).
    #define Z_SAFE_HOMING_Y_POINT ((Y_BED_SIZE) / 2) // Y point for Z homing when homing all axes (G28).
    #endif

    I believe would have to change the calculations to get it to the center. Though do not need a perfect center location.

  4. #4
    I fixed it. Yay!

    I had the #define X_MIN_POS 0 and #define Y_MIN_POS 0 screwed up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •