Close



Results 1 to 2 of 2
  1. #1

    Exclamation Anet A8 auto Home not working

    I am using the most recent version of marlin, which I installed onto my Anet A8 printer. For some reason the auto home is no longer working on the Z axis. When I use the auto home function the printer homes the X and Y axis, then the Z moves up but not come back down. I have reinstalled Marlin (the same version as the one I had installed before) and still the problem persists. This is not an error with the firmware as the printer was working fine even after the first installation of marlin. I have also tried just unplugging the Z axis home switch, which did not work either.
    Please give me any suggestions. Thank you.

  2. #2
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Location
    Washington State, USA
    Posts
    660
    Add Roberts_Clif on Thingiverse
    When flashing new firmware you need to send code to read the firmware and store the firmware configuration into memory.

    To do this send
    M502 - Factory Reset
    // If you need a different Z-Offset you can enter it here
    // M851 - XYZ Probe Offset
    M500 - Save Settings
    I do this from Cura 15.04.6 in terminal mode

    This can also be done from LCD
    Load Settings
    // If you need a different Z-Offset you can enter it here
    // M851 - XYZ Probe Offset
    Store Settings
    Last edited by Roberts_Clif; 11-24-2019 at 03:59 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •