Results 1 to 2 of 2
  1. #1

    possessed printer or do stepper motors kill printers

    I am trying to work the bugs out of my makerfarm 10" i3v just seeing if you could help.

    So here is my dilemma.

    I used to love printing with it... until it started to have some ghost in its works. It started one day out of the blue. I print PLA on it mostly. I had it set up to use octopi as the interface that I would upload files to it. The symptoms I am trying to diagnose are as follows

    It started printing and about 5 - 10 min into the print the LCD from the ramps board would get garbled (ie show random characters in no real understandable language. The X, Y and Z coordinate areas of the display would change to random characters supposedly to the characters that should be numbers. the print would randomly fail. Sometimes the print would finish and others it would not and fail with the nozzle over the print with the print nozzle still hot and the bed still hot or both would cool to ambient. I could never figure a pattern.

    things i did to diagnose / fix the problem. (Not necessarily in this order.)

    1. I read that interference or noise may be entering the system from the ac voltage. I got a HUM X from ebtech that is supposed to eleminate any interference from the mains voltage (apparently it's for high end audio equipment). RESTULT = same as above
    2. I wrapped all of the stepper motor wiring and electronics wiring in foil to eleminate interference. RESULT = same as above.
    3. put ferrites on all wiring. RESULT = same as above.
    4. changed RAMPS boards. RESULT = same as above.
    5. changed stepper drivers. RESULT = same as above.
    6. Changed the psu. RESULT = same as above
    7. changed heat bed relay. RESULT = same as above.
    8. changed LCD board. RESULT = same as above.
    9. tried printing from astro print. RESULT = same as above.
    10. tried changing USB cables from pi to RAMPS. RESULT = same as above.
    11. Tried different raspberry pis. RESULT = same as above.
    12. tried printing directly from SD card from both of my LCD boards.... RESULT = same as above.
    13. tried different SD cards. RESULT = same as above.
    14. checked all wiring and made sure no kinks or cut or frayed wiring. RESULT = same as above.

    I've basically rebuilt the machine electronically except for stepper motors and end stop micro switches...

    SO my question is: Should i change all stepper motors and end stops next? Do you think it could be a bad stepper causing this persistent gremlin? I am lost.. I cannot get a good print.

    thanks for any help.

  2. #2
    Engineer Roberts_Clif's Avatar
    Join Date
    Jun 2017
    Washington State, USA
    Add Roberts_Clif on Thingiverse
    I had an electrical interference with my Hictop 3DP11/12 3D Printers.

    Went through the same problems you spoke of.
    I finally moved the LCD/Rotary Encoder to a different location on the 3D Printer. This turned out to be the Front 2020 T-Slot support.
    I wrapped the LCD/Rotary Encoder ribbon cables with Blue Painters tape, to cover them a stickier Aluminum Foil Duct used to Taped them to T-Slot.
    I routed the cables to the closest edge, Following the T-Slot to the front.

    Now I placed the LCD Cable on the bottom of the T-Slot, an placed the Rotary Encoder cable to the Inside edge of the T_Slot.
    This is because every-time I wrapped the two Cables together received the display garbage.

    One Last Note I grounded the Aluminum Foil Duct to the 12/24VDC Power Supplies. As I had two 3D Printers experiencing the same delima.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts