Close



Results 1 to 2 of 2
  1. #1

    Marlin Configuration fails - SKR MINI E3 DIP on MPSM V1

    Hi, I'm new to marlin so forgive me if this is a newbie question. I did look online and couldn't find anything useful.

    I have a Monoprice Select Mini V1 that was my first printer and it served me well for a couple years. It came to a point that it needed maintenance so I replaced all belts and pulleys with GT2 6mm. Changed the Z motor to a proper stepper and T8*8 lead screw and E3D V6 clone.

    When I went to update the firmware the update failed and damaged or erased the boot loader so it wont take code through micro SD slot. I will eventually learn how to use my ST-Link V2 or maybe the Arduino or FTDI or all of the above to try to save that board.

    For now, I was trying to set it up with my SKR MINI E3 DIP

    I followed the instructions on the Bigtreetech github about changing the .ini file for the steppers. The steppers is what the build gets stuck on but maybe not. It just keeps telling me I need git client installed. I installed it and rebooted and tried a few different things but it still has errors.

    When i go to "build" in platformio it tells me:

    Processing BIGTREE_SKR_MINI (platform: ststm32; framework: arduino; board: genericSTM32F103RC)

    Verbose mode can be enabled via -v, --verbose option
    CONFIGURATION: https://docs.platformio.org/page/boa...M32F103RC.html
    PLATFORM: ST STM32 5.6.0 > STM32F103RC (48k RAM. 256k Flash)
    HARDWARE: STM32F103RCT6 72MHz, 48KB RAM, 256KB Flash
    DEBUG: Current (stlink) External (blackmagic, jlink, stlink)
    PACKAGES: tool-stm32duino 1.0.1, toolchain-gccarmnoneeabi 1.70201.0 (7.2.1), framework-arduinoststm32-maple 1.10000.190819 (1.0.0)
    Converting Marlin.ino
    LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
    LDF Modes: Finder ~ chain, Compatibility ~ soft
    LibraryManager: Installing TMCStepper
    UserSideException: Please install Git client from https://git-scm.com/downloads:
    File "C:\Users\reefs.platformio\penv\lib\site-packages\platformio\builder\main.py", line 126:
    env.SConscript("$BUILD_SCRIPT")
    File "C:\Users\reefs.platformio\packages\tool-scons\script..\engine\SCons\Script\SConscript.py", line 541:
    return _SConscript(self.fs, *files, **subst_kw)
    File "C:\Users\reefs.platformio\packages\tool-scons\script..\engine\SCons\Script\SConscript.py", line 250:
    exec file in call_stack[-1].globals
    File "C:\Users\reefs.platformio\platforms\ststm32\build er\main.py", line 91:
    target_elf = env.BuildProgram()
    File "C:\Users\reefs.platformio\packages\tool-scons\script..\engine\SCons\Environment.py", line 224:
    return self.method(*nargs, **kwargs)
    File "C:\Users\reefs.platformio\penv\lib\site-packages\platformio\builder\tools\platformio.py", line 122:
    _build_project_deps(env)
    File "C:\Users\reefs.platformio\penv\lib\site-packages\platformio\builder\tools\platformio.py", line 47:
    project_lib_builder = env.ConfigureProjectLibBuilder()
    File "C:\Users\reefs.platformio\packages\tool-scons\script..\engine\SCons\Environment.py", line 224:
    return self.method(*nargs, **kwargs)
    File "C:\Users\reefs.platformio\penv\lib\site-packages\platformio\builder\tools\piolib.py", line 1043:
    project.install_dependencies()
    File "C:\Users\reefs.platformio\penv\lib\site-packages\platformio\builder\tools\piolib.py", line 878:
    lm.install(uri)
    File "c:\users\reefs.platformio\penv\lib\site-packages\platformio\managers\lib.py", line 359:
    force=force)
    File "c:\users\reefs.platformio\penv\lib\site-packages\platformio\managers\package.py", line 701:
    track=True)
    File "c:\users\reefs.platformio\penv\lib\site-packages\platformio\managers\package.py", line 486:
    vcs = VCSClientFactory.newClient(tmp_dir, url)
    File "c:\users\reefs.platformio\penv\lib\site-packages\platformio\vcsclient.py", line 49:
    silent)
    File "c:\users\reefs.platformio\penv\lib\site-packages\platformio\vcsclient.py", line 63:
    self.check_client()
    File "c:\users\reefs.platformio\penv\lib\site-packages\platformio\vcsclient.py", line 130:
    "Please install Git client from https://git-scm.com/downloads")
    ================================================== ==================== [FAILED] Took 1.50 seconds ================================================== ====================

    So i went and downloaded and installed the items. then tried again, same problem, I re-started the computer. Tried again, same problem. Then, tried to close all folders and windows and everything in Visual Code/ Platformio close everything try again same problem. My computer is up to date as is VS and Platformio. I'm using marlin 2.0. What am I doing wrong???

    thanks for any help
    Last edited by Reefsider416; 10-04-2019 at 10:41 PM.

  2. #2
    This issue has been fixed. I believe it was an issue with not having the latest release of marlin even though the file name and release version were the same. the env was different after deleting and re-extracting marlin. I also uninstalled and reinstalled VS code and moved the folder to the C drive with less nesting.

    Fixed all errors and compiling fine now :-)

    New problem; I can't get any of my computers to recognize the board at all. I tried my windows 10 machine and my imac neither even acknowledge anything is plugged in. I tried 3 different usb cables also just in case but nothing.

    I tried to download the maple drivers but i can't figure out what to do with them. I tried finding the drivers/win folder but i can't find it anywhere. there is a folder drivers and a folder mydrivers but no win folder inside that.

    any suggestions whats going wrong now?
    Last edited by Reefsider416; 10-05-2019 at 10:12 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •