Results 1 to 2 of 2
  1. #1

    FLSUN 3D i3 [2016 version]


    I have a Flsun 3D i3 (Prusa copy). It was I believe running 1.1.0, I've now upgraded it to 1.1.9 using the same settings, usefully taken from one of the users on this board!

    On the x carriage, using pronterface, I can move my x axis left or right with no problems. It responds in the correct directions. The XMIN is set as -1 and the endstop is positioned on the X head, it's triggered by it hitting the frame on the left hand side.

    When I run M119, the XMIN triggers when ever it is pressed. I believe therefore it's doing the right job. However it appears to control the right side, not left - so once it's triggered it won't go right anymore, but it will bash itself into oblivion into the left (homing area)

    It also does this on the Y axis. The Z axis seems fine at present.

    How do I tell it that "left" is where the endstop is, not right?

    In my configuration.h

    #define X_HOME_DIR -1
    #define Y_HOME_DIR -1
    #define Z_HOME_DIR -1
    Attached Files Attached Files

  2. #2
    ha, ignore me.

    I have solved my problem. Both axis had software min endstops on. They were inverted. This was not the end of the problems.

    The PLA had degraded or got damaged on the x-axis and the x-axis endstop had fallen behind the zipties that hold the belt in place. Tightening the screws would have been enough but the PLA just crumbled.

    The y-axis was behaving the same, but it was due to a cable being in the way. D'oh.

    The z-axis wasn't triggering because a wire had come loose.

    When my friend tidied up the wiring (he's neat like that) he'd rewired the bed to the hot end and the hot end to the bed...

    Fun times.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts