Page 10 of 10 FirstFirst ... 8910
Results 91 to 100 of 100
  1. #91
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    well I plugged everything in, and powered it up.
    No smoke ! - Result :-)

    The dual z motors work - steps are clearly off, but they both turn together :-)

    That said all the axis appear to be reversed.
    Endstops don't appear to have registered and axis home in the opposite direction to the stops.

    But the screen works.
    And nothing explided or caught fire.
    So I think it's mostly a case of working through the configuration file and seeing what's what :-)

  2. #92
    Figured some issues from here

  3. #93
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Tracked down the problems - for some reason it's not updating the config file.
    So it still thinks it's a delta.

    Tried all the stuff it says on the various wiki's.

    Just not updating settings.


  4. #94
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    I've given up on the mks sbase.
    Not sure if it's me or smoothieware, but it's either not updating the configuration file - or it's not reading it properly.

    So as I also have an unused mks Base 1.5 - I've decided to go with that and - at least to start with - marlin.
    I know I know. But I found this page:
    And as far as I can see it's also a straight swap for the second z-motor to the second extruder socket.

    From what I've read for a z-axis (very slow speed, high torque) you either need to wire in serial - and after looking at a bunch of articles and diagrams, it still does not make any sense - or use two stepper driver sockets.
    The fact that creality actually make boards where the two z-sockets are hardwired in parallel, sharing the single driver chip - is enough for me to want to not do that :-)
    It's clearly a cheap and nasty option ;-)

    And given that what i have is essentially an anet a8 clone and the exact same board and screen hardware - this looks like a good option.

    Shame about the smoothieware - but it just does not do what it says it does. Newer firmware doesn't even load properly on the sbase board.

    We'll see :-)

    At least this way I can hassle Autowhiz when marlin gives me hassle, lol

    Oh yeah talking about cheap and nasty. Not only does the ctc board Not come with a bootloader, it is also missing the pins that you use to program it with an add on module.
    The chips must be installed preprogrammed, I guess that the fact they also use an atmega 128, is why they use such an old and nasty version of marlin.

    I actually wanted to use my cheaper lcd screen with the knob/button as the touch screen is a bit 'touchy'. It's pressure not conductace and has a tendency to activate the wrong button or two at once.
    But for the life of me i can not remember where I put it and I've spent a couple hours looking for it to no avail.
    If it turns up I can add it - hell it's already installed in a holder and mount - should make it easier to spot, right ?
    Yeah you'd think so lol
    Last edited by curious aardvark; 02-24-2020 at 02:48 PM.

  5. #95
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Well, I don't think it's the boards.
    Both have different firmwares installed, both have the pre-heat temps at 200/65 and the screen shows exactly the same options and settings 180/50 for both.

    Somewhere down the line the screen is just not communicating with the board properly.
    I know it's communicating as you can sort of get the stepper motors to move. Albeit the wrong way.
    So the baud rate is correct - hads to change from 250000 to the standard 112500 (or wahtever) as arduino ide simply doesn't ever give you and option for 250000. (on of the many reasons I hate it)

    I've checked the config and firmware on the screen and as far as I can see it's what it should be.
    Board programmed first time without any hassle, so I know the settings went through okay there.

    At this stage all I can do is try and find the missing screen. I mean it's already installed on a mount it has to be in my workshop somewhere !

  6. #96
    Keep posting this kind of stuff

  7. #97
    I actually learned several good things from here

  8. #98
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Right - found my other screens.
    Turns out the new marlin firmware on the mks base 1.5 is actually set up for a reprap full colour smartgraphics, NOT the mks tft touch screen. Well that explains that, but not the smoothieware where the screen was defnitely set for the tft.

    So I happen to have the correct screen. plugged it in.
    Powers up but nothing show on the screen.
    This rings a vague bell from when i originally got the sbase board.
    It's a dead screen :-(

    So now I'm looking for the mks tft screen library for marlin in the hopes I can get the touch screen going. Failing that I still have an unused dirt basic 6 line lcd display I can use.

    I'm beginning to regret I ever started this in the first place lol

    Still if I can ever get the machine working again it should be worth it :-)

  9. #99
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    right then, As I really like repetier I thought - I'd see about setting up that instead of marlin.

    First thing - repetier has a really cool online configuration setup.
    You basically work through a few pages of settings and then download either the full firmware with new config or just the config file.
    NICE !

    It also specifically asks if you have 2 z axis motors and then asks which stepper you want to use for the second motor. Also NICE !

    The only issue I have is that I was going to use my third (bog basic) screen. But it's DZ2004A-V1.2 and I have no idea which one I should pick from the list. Obviously nothing has that name - that would be far too easy !

    So , for the moment I've stuck the reprap full graphics smart controller in - you never know it might work on repetier.
    Failing that - I'll see if I can find a way to use the mks tft touch screen or the real basic screen.

    Apart from that it was the easiest config I've ever setup.
    Now to move the machine back over here and plug it in and see how the actual firmware upload goes !

  10. #100
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    I'm not sure I've mentioned how much I dislike arduino ide ?
    So just in case that's slipped by you: AAAAARRRRGGGGHHHHHHHHHHHHHHHHHHHHHHHHHHHH !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    That's better ;-)

    I ran through the repetier config process, connect the board, load the repetier.ino file and - obviously - get an error.

    Apparently ide doesn't think that something in the sd card setup is right.
    I can't see anything wrong, and - obviously - it won't tell me exactly what it thinks is wrong, so it won't compile or upload the bloody firmware.
    At that point I swore copiously and gave up for the night.

    I'm currently contemplating just giving up entirely and putting the thing back together with the original board and screen.
    I have now modified the z-axis endstop so that it's a simple bolt screwing through a nylon locking nut, which was the only physical issue I had with the machine.
    Once you screwed the bed nuts down so that the springs are really tight - it was almost impossible to adjust the end stop bolt as it used three nuts that you couldn't really get at.

    Now it's just a simple hexhead bolt that goes up and down without any hassle and won't move by itself.

Page 10 of 10 FirstFirst ... 8910

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts