Flash Forge Adventurer 3

Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40
  1. #31
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    why is this stuff so bloody complicated.
    The annoying thing is I can't start using the machine until I can change the configuration. Well I could print a couple 10 and 20mm cubes. measure it and work out the percentage it's printing too small and then resize each print to that degree.
    But that would mean I'm still stuck with the acreen and baud rate and as it's on an extended usb cable, it really doesn't like that high a baud rate.
    I could move it nearer, but since i switched to flashprint, I'm now using the klic-n-print a lot more (it just works and I never got simplify 3d to work with it properly ) and want to get into some exotic dual filament printing. So that's stayiong where it is and the i3 will have to live with the long cable.

    Plus I'd rather use the better screen with the full size sd card onboard anyway - since I've got it and it doesn't count towards the budget :-)
    Plus IT's already attached to a mount and ready to be scrwed to the frame :-)

    So far nothing has been able to either talk to the board or if it can talk, won't update firmware.

    Last thing I saw was a chap who used the latest ide and marlin firmware and just swapped out the configuration.h and added some acceleration settings.
    I'll try that today - assuming I can find the post again lol.
    If that doesn't work - I'm currently out of options.
    Given that my backup board doesn't have 2 z axis motor sockets, not sure how you go about re-purposing the second extruder socket (can't remember if it had one or not now lol).
    I suspect that'll be pretty heavily covered in various places online.

    So to sum up the: cheapest 3d printer on ebay experience so far.

    Nice hardware, shame about the 'brain'.

    It is weird that a company would deliberately release a machine with incorrect settings in the firmware.
    I presume the boards are mass pre-programmed on the production line, so ctc probably don't have the software to change the configuration. Given that it wouldn't cost them anything to release it - and not releasing it is doing them harm, I dunno, just seems bizarre.
    I do sometimes wonder about the marketing side of these chinese companies.

    Right, lets see what marlin 2.0 will do for us !
    Last edited by curious aardvark; 10-13-2018 at 06:47 AM.

  2. #32
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Did i already mention how much I dislike arduino ide ?
    The only place I've found to set the baudrate is: tools, serial monitor. Where i set it to 250000 and it seems to work fine.
    However when i come to upload I get this in the error message:
    C:\Program Files\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega1280 -carduino -PCOM2 -b57600 -D -Uflash:w:C:\Users\Alex\AppData\Local\Temp\arduino_ build_722464/Marlin.ino.hex:i

    System wide configuration file is "C:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf"

    Using Port : COM2
    Using Programmer : arduino
    Overriding Baud Rate : 57600
    avrdude: stk500_recv(): programmer is not responding
    And as far as I can see that's the reason it won't upload.
    Had a look at avrdude.conf and it says: don't edit this file as it will be overwritten next time you compile.

    Which would suggest that something, somewhere is telling it the baud rate is 57600.
    Last edited by curious aardvark; 10-13-2018 at 09:03 AM.

  3. #33
    Hmm, I don't think that's the problem, I have multiple boards that use either 250000 or 115200 bauds and Arduino programs the fine, no need to change baudrates. I'd check the board for bootloader; if it doesn't have one, the upload won't work that way. Instructions for uploading without bootloader:

  4. #34
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Hmm, that looks bloody complicated. Plus apparently these boards have been programmed with ide.

    How on earth do you 'check for a boot loader' ?

    This is what it tells the computer when it's hooked up:

    Is there anything to suggest whether or not it's got a bootloader ?
    Attached Images Attached Images

  5. #35
    That output is from the actual firmware which I think doesn't know or care about bootloader. Can't remember if the boards with a bootloader print anything else during boot...
    Haven't had any bootloader-less boards so can't be sure, but the way to check if there is a bootloader actually is to try to upload the firmware using the USB connection; it it uploads, you have bootloader. If not, no bootloader. And if no bootloader, you need the thingamajig USBtinyISP to program the board.

    Alternative for modifying the firmware is to use gcode-commands to change settings using the USB-connection. Pronterface is good for this, as is Octoprint. Haven't used S3D or other USB interfaces. Octoprint even supports Marlin EEPROM editing with a plugin. If the board has EEPROM enabled, you should be able to save the settings with M500-command. If not, you need to issue the commands every time printer is started.
    You can change axis steps with M92-command From your firmware output it seems that current settings are X78.74, Y78.74m Z2560 and E105. So modify the M92 line for correct steps, they should be active immediately.

  6. #36
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    many thanks - I'll give that a try :-)

    Just spent a couple of hours tracking down the correct version of replicaotrg to calibrate the nozzles on the klic-n-print.

    even if it doesn't stick permamently - I can always put the axis change script in the simplify3d start-up script for the printer.

  7. #37
    Join Date
    Jul 2016
    South Florida, USA
    Add AutoWiz on Facebook
    Hey CA, i have learned a stupid little emotional problem that arduino seems to have. While i do not understand the why, It is well documented if you just search around for it. If you open your arduino file by double clicking on the file itself, then there is a good chance it will not write to the board. However, if you just open the arduino ide first. and then open the file from the arduino environment suddenly things work and write. Wierd problem but very simple fix. I'm not sure if that is what you are describing or not.

  8. #38
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    I've only ever opened ide first and then the 'marlin.ino' file.
    So I'ts probably not that.

    Currently waiting for some 3mm lock-nuts (?1.44 for 50 inc deliver from uk - mad) I'll incorporate them into good grip wheelie things (lol must be a proper word for a notched edge wheel). That will make bed levelling both easier and hopefully - why I'm going with lock nuts - longer lasting.

    I did comtemplate drilling the bed holes to 4mm as I already have 4mm lock nuts. But I don't have appropriate length 4mm bolts - so is cheaper and easier to just buy the locknuts and avoid drilling right on the edge of the plate.

    Now I've read that some people have had success uploading firmware with the board just plugged into the usb. I did try removing the 12volt power wires - but no joy just on usb.
    So I think I'll unplug everything and try it like that.
    All the other boards I have, work fine just on usb - obviously you can't run motors. But with just the board plugged into just the usb - they usually fire up.

    So that's probably next, on the firmware saga.
    As I've got the bed to bits anway.

    On another topic entirely. Picked up a couple of tubes of dimafix at tct this year.
    It's some clear liquid in a plastic tube with a dabber type top.
    So I put 3 layers on the klic-n-print.
    No noticeable drop in liquid level in the tube.
    So far did about 5, largish prints - 4 in the same place. second nozzle was causing issues on the overhang curl, so the last one - which worked was rotated.

    Got the first layer speed up to 40mms. THis is a 120mm long print. No sign of warping.
    Printed at 65c and once bed had cooled prints came off easily.

    No sign of wear.
    Have to say I'm very impressed with the stuff.
    Hot end on delta is currently under repair. Struggling to get the teflon tube exactly right length and placement. So klic-n-prit is currently the main machine lol
    The dimafix stuff, almost gets it up to the same print speed as the delta.
    Interested to see how it lasts. But so far - seriously impressed.
    Last edited by curious aardvark; 10-16-2018 at 06:55 AM.

  9. #39
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Okay so here's the thing.
    Just a bit of general advice :-)

    If you are trying to get a filament feed tube out of one of those weird tube holder things.
    The things at the bottom of the pic:

    Particularly if you're using 1.75mm filament and the tube has internal diameter of 2mm.
    Finally tracked the issue with the delta down to this. Basically I've buggered the internal diameter of the tube and the extruder can no longer push filament past where I used the pliers.
    The hotend and nozzle side of things is absolutely fine.
    New tube arriving today. And some spare connector doodads as I can't get the old tube out of them any more. Not even with pliers :-)

    So tuesday's lesson is:
    Never assume, you know FOR CERTAIN, what the problem is :-)

  10. #40
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    locking nuts and some 30mm fans arrived today - killed the wiring on the delta heatbreak fan with all the fiddling about.

    So thinking I might just adapt the delta cooling duct for the ctc, instead of trying to figure out how the hell you attach a turbofan to anything :-)
    Not sure they could have made those things any more awkward to work with if they'd tried.

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts