Close



Results 1 to 5 of 5
  1. #1

    Help me with my 3D printer

    ISSUE: Stepper motors are not working when connected with RAMPS 1.4.


    OBSERVATION: The LED lights(LED 2,3,4) in the RAMPS 1.4 is not powering up.


    PRATICES: I use Arduino mega 2560 and installed marlin firmware in it. And I bought a RAMPS 1.4 in a local electronic dealer. I placed the RAMPS over Arduino mega 2560. For testing I just connected 2 NEMA 17 stepper motors with RAMPS. When USB port connection is given from laptop to arudino board, a LED light is ON in Arduino board(L) and in RAMPS(LED 1). I use SMPS 12V 20A as a PSU for RAMPS. But in RAMPS the LED 2,3,4 is not switched ON. I checked the input voltage to the RAMPS using micrometer and it shows 11.75V. But there is no output from the RAMPS. The stepper motor isn't powered up.


    Also I installed and tried Repetier firmware and grbl but it doesn't work.


    When I flashed Arduino with grbl, in this case all the LED lights in arduino and RAMPS 1.4 is switch ON. I use Candle GRBL software to test the stepper motors.


    And I replaced and tested with another RAMPS which is bought from Amazon but the problem remains unchanged.


    kindly give some suggestions at the earliest.


    Thanks and regards
    Baalaji V
    Attached Images Attached Images

  2. #2
    Seems like you got the same driver chips as me. Have you tried using the other driver chip? cause on my printer, one of the drivers died on my very first print halfway thru, maybe yours is dead already. Put the wires from your stepper motot onto the other driver port and see if you still have no movement or wrong movement.

    When my driver died, the motor just jumped back and forth uncontrollably.

  3. #3
    I have already tested my drivers with CNC shield. It is working properly. The stepper motor runs perfectly.

    thanks with regards
    Baalaji V

  4. #4
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Posts
    8,503
    have you also got the endstops connected ?
    might make a difference.

  5. #5
    No I didn't connect the end stoppers
    Thanks and regards
    Baalaji V

    Quote Originally Posted by curious aardvark View Post
    have you also got the endstops connected ?
    might make a difference.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •