Pronterface refuses to connect to my printer. The monitor just says "connecting..." and stays that way. Both the board and pronterface are using COM 8. Baudrate is 250000 on both. I have tried changing the baudrate. I have tried a different USB cable and port. I have made sure that Arduino and Pronterface are not running at the same time. The board can connect the the Arduino IDE without a problem, and uploads the code just fine. I have tried uploading some test code, which works perfectly, moving all motors and heating up the hotend. I am assuming that it is a firmware problem, but I don't know where to begin. I have tried two different versions of Marlin with no success, as well as resetting the board. Nothing has shown up on the serial monitor.

Whenever the board is unplugged, I get this:

[ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed
[ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed (WindowsError(22, 'The device does not recognize the command.'))

Using RAMPS 1.4 with Arduino Mega. This is the second board that I have tried.

Here is my config: