Close
Flash Forge Inventor Series



Results 1 to 3 of 3
  1. #1

    Brand new X-PRO not powering on

    So, bit if a panic here (holiday tomorrow, trying to decide if I need to post a return today).


    I've e-mailed QIDI and waiting response, but meanwhile seeing if anyone else has a suggestion here.I just received a X-PRO and we went thru all the setup carefully. And then it doesn't power on. No light, fan, or nothing on the LCD.The box looks undamaged; however I did notice we had to slide the upper syrafoam piece a bit in order to remove it (this didn't appear to the case for other box-opening videos we had watched), so I was a little curious about that.

    I tried the power plug that it came with; that didn't seem to fit very snug. So I used another power plug (regular compute PC black power plug) that seemed to fit better; still no power up. (we are in Texas, and the brown box for the power plug was correctly checked United States)

    I peeked at the red power switch on the side, which it says 230V on it (which shouldn't need to be adjusted).

    I hope I am just missing something (a secondary switch?), as I really don't want to go through a return hassle (and ruin the holiday where my daughter was excited to do her first day of 3d printing). We installed the turbofan assembly, all the wires seem/look fine to me.

    I checked the fuse, it looks ok to me (solid silver wire going full across it).

    I tried two different outlets. One outlet runs a circular saw, so it should be getting healthy volts/amps.

    Suggestions appreciated!
    Last edited by voidstar78; 07-03-2018 at 12:14 PM. Reason: formatting

  2. #2

    up and running

    Yeah, I'm not running this thing on my Washer/Dryer circuit!!I flipped the red-switch on the side to 115V and now it is powering on just fine.Not sure if this means the heating won't get as hot as it needs to be? (this is my first 3d printer!)There is a sticker over this red switching stating "The power has been setup. Please do not change again." Hope I'm not voiding a warranty by changing it Anyhow, now to see if it actually prints! Slight fault if they shipped it with the wrong settings for this country.

  3. #3
    Confirmed from QIDI: "Firstly, please convert the power switch to 115V which suitable for your place's voltage."Simple fix, this unit just wasn't configured correctly for my region (North America). This same kind of switch can be found on power supplies for computers, just I was paranoid since this was a brand new printer and I didn't want to assume anything about it.Fuse is fine, and we've printed a couple things now (semi successful; will need to dial in temperature and speeds for the material, as usual). The "out of the box" example printed just fine, but it's not very exciting: a simple rectangular solid that took ~53 minutes to print. Then we sliced one of those toothpaste rollers and printed that; it's functional, but the key-end of the turning knob is just a little bit rough (I rotated it before slicing, probably shouldn't have). Anyhow, we're on our way to learning what this 3d-printing stuff is all about

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •