Close



Results 1 to 6 of 6
  1. #1

    Marlin firmware, sail fish and stock newbie questions

    why upgrade the firmware with sailfish or marlin; what is the benefit and drawbacks?

  2. #2
    Student
    Join Date
    Jul 2018
    Location
    Canada
    Posts
    7
    I did an upgrade on my Makerbot 2 printer.
    I installed an heated bed.The original firmware doesn't allow for this, so I have installed the sailfish firmware. It allowed me to control the heated bed temperature and this firmware has additional options that are not available on the original makerbot 2 firmware.


    https://voltatek.ca

  3. #3
    Student
    Join Date
    Jan 2019
    Location
    Jersey
    Posts
    4
    Add NeilP on Thingiverse
    Odd, I have just come to this forum to find out about a Makerbot 2...

    I am sure latest MB Rep2 firmware does have heated bed option. Mine has RevG Maim board.


    When you go to this open source firmware can you go back to Makerbot Original firmware or is it a one way process?

    thanks

  4. #4
    Student
    Join Date
    Jan 2019
    Location
    Jersey
    Posts
    4
    Add NeilP on Thingiverse
    Another dead forum
    thankfully I did not buy my MakerBot printers! I was given them both.

    Tried posting on other 3-d forums about MakerBot, no replies....My fault, though, does not seem to have been much activity on it ever since and the most was about 2014. Also near Zero response from their own Support people.
    $2500 worth of kit here, and seems no chance of help with it. Two expensive black turds with no community and no manufacturer support, now I see why I was given them! Glad I never shelled out money on them !

  5. #5
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Posts
    6,801
    when makerbot were taken over, things went rapidly downhill.
    They have yet to improve.

    which makerbots do you have neil ?
    There is no reason you can't drop a standard board in and just use as a replicator clone - kinda ironic, but at the end of the day a 3d printer is just a collection of stepper motors and sensors (just endstops for the replicators).
    Most boards work with most printers.
    As do most firmwares.
    As the rep 2 only uses one motor per axis - then pretty much any board that supports 2 extruders will be able to run it.

    The problems started with the version 3 (I think) that's the one that had no heated bed, and did they roll out the so called 'smart' extruders - which turned out to be anything but :-) - for them as well ?
    Those 2 things pretty much killed makerbot as a serious company.

    Replicator 2's should still be decent bits of kit and easy to fix.

  6. #6
    Student
    Join Date
    Jan 2019
    Location
    Jersey
    Posts
    4
    Add NeilP on Thingiverse
    Thats for getting back to me, was beginning to loose hope.!

    I have two MakerBots, a Replicator 2, the early version without the spring on the X-axis end stop switch and a MakerBot Mini with a pair of basic Smart Extruders.

    Both low hour machines.

    The Rep2 has a Revision G 'Mightyboard'...what is it with giving the boards such daft names...the board in the gantry of the Replicator Mini, that the feed motor etc is connected to, is called a 'Bronx' board...that is the one that has the LED on the head driven for ..The LED has failed..not big deal though, had been told I need a new " Bronx" board to get it working again. have cut the wires off it and tested it , the LED works fine it is the driver circuit or software not firing up the LED...so I'll run a pair of wired to it from a CC/CV board from e-bay for ?4


    So they were taken over, that explains the poor Customer Service.


    Was wondering about 'SailFish' firmware, but that seems to have dried up too, all references to it and threads about ti seem to stop in about 2014.

    The mainboard in the Replicator 2 is as I said, a Revision G, and it has heated bed and second extruder outputs. If I could reflash that , that would be good.
    Otherwise a new board is not going to be a big job...ATMega 2560 ? something like that ?




    Today I have been experimenting with the MakerBot Mini. with its so called 'Smart' extruder. Yes it has auto height adjustment...but at only one point on the board, at the back. The horrid little plastic bed is not level in the Y-axis direction, not by much but it is enough . and because the Smart extrude only works on one point tit can't even compensate for the t..very poor firmware.

    The head during its homing routine' hits the removable bed carriage and burns itself in to the plastic of it., see pics.
    Trying to see if I can shim it out.

    Trying various prints of same test piece, with the old Makerbot Desktop and the Newer Print Software.

    'Print' has a greyed out homing button, and no option to hit a "default settings" to return to standard. All the various Save As setting options seem greyed out too.

    Currently the Mini prints OK, but any item is fully melt din tot he raft and changes settings does not seem to change that .

    So going through , with this test piece and changing things one setting at a time. to see if I can get a usable print from the Mini, or if it will be consigned to the scrap pile.

    Such crappy software.

    Some times the software , either via USB or WiFi connection will not fully talk tot he printer..hit the "Settings ' button ..and nothing, the button changes colour..but not setting s window pops up. such bizarre behaviour. totally random as to if it will work or not..
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •