Close
Flash Forge Inventor II Spring Promotion



Results 1 to 2 of 2
  1. #1

    Creality 3d printer mishap

    Hi there,

    I recently just got a creality 3d printer (cr10) and was pretty keen on setting it up as quick as possible to start printing. After setting everything up, I was able to calibrate it and tried to print a Benchy as a test print. However, as soon as it started to print the 3d printer decided to shut down and I was left feeling confused. I checked the LCD and it was black, and all I could here was the whirring coming from inside of the machine box, however the printer itself wasn't printing anything. Feeling perplexed, I waited a bit and turned everything off and once everything was quiet, I turned everything on again. Still the same whirring and black screen from the LCD. So, i decided to do something which I regret, which was to turn everything off, and turn the power supply (at the time was 220V here is Australia) to 110V. Immediately after I did that, a loud BANG came from the machine box and everything went quiet. I tried turning it on and off again but the machine isn't responding... Any ideas?

  2. #2
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Posts
    5,892
    Yeah you've just blown up the power supply by feeding 220v into a 110v circuit.

    Hitting the reset button and checking your initial wiring would have been better things to try.

    As it currently stands you're going nowhere until you get a replacement power supply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •