Results 1 to 2 of 2
  1. #1

    Repeated filament jams

    My trusty Creator Pro, roughly 2 years old, has begun having serious filament jam problems in the right nozzle, the one I use most. The filament gets stuck with a blob on the end and a thin place in the middle, in such a way that it can go neither forward nor back. These photos show the anatomy of the problem. This came on gradually, with more and more frequent jams, more and more difficulty inserting filament and getting it to go all the way down. It took things apart and put them together taking great care to align everything properly, but no help.

    Then I started using my left nozzle, and it loads and unloads with all the smoothness I used to be accustomed to on the right.

    Is this a familiar experience? Is there some part of the printer that wears out?



  2. #2
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    sounds like maybe the heater cartridge might be on the way out.
    Do the temperatures look okey when it's jamming ?

    Ah - looking at your picture, the filament is not feeding into the hotend. It's gone off to the left hand side.

    Usually you only get that with flexible filaments.

    Maybe something stuck in the feed hole.

    Me, I'd strip the extruder down and make sure there wasn't a blockage anywhere.
    Having done it recently - it's pretty simple.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts