Flash Forge Inventor II Spring Promotion

Results 1 to 4 of 4
  1. #1

    Monoprice select plus homing (Z axis) - need help

    My boys and I just got a Monoprice Select Plus 3d printer for Christmas and I'm having trouble figuring out to how to home the printer. Something doesn't seem right and I'm not sure if it is something I am doing or if there is a hardware issue.

    What I'm doing and what I'm seeing:

    I turn the printer off and I adjust the horizontal bars to the same height on both sides from the frame.... this printer does not have synced z-axis motors, so I do this first to the the print head somewhat level to the build plate. I then bring the print head all the way down and adjust the build plate to a piece of paper thickness from the nozzle at all 4 corners. At this point I don't see how I am doing anything wrong. But it seems like the printer just isn't doing what it is supposed to once I turn it on.

    When I turn the printer on, and choose the Home option, the print head appears to be properly finding the home position in the X and Y axis, but the Z axis it always lifts up about 1/4 - 1/2 inch. and it does that EVERY time the home option is chosen from the menu. If you push home enough times the print head will hit its max height. It never seems to move DOWN and find the real home position.

    Just to see if it really knew where home was I tried to print something from the provided SD card and it just prints at the same height it moved to which right after my manual calibration is about 1/2" above the build plate. How do I tell the thing where its 0 point is on the Z axis?

    What am I doing wrong? Do I have a sensor not connected somewhere? Is there a problem with my unit?

  2. #2
    Join Date
    Jul 2017
    Sounds like a firmware issue. Try running it from a host software like repetier or pronterface, see if you have the same issue.

  3. #3
    Well, it wasn't firmware, but the software you recommended showed me that it did the same thing with pronterface... it took me quite a while to get that software running in ubuntu 17.10 since there are some newer packages in that that pronterface doesn't exactly work well with.

    BUT... it still kept going up in the z axis. I finally found that the z axis lower limit switch was stuck in the depressed position. I took it apart and popped it back up and it seems to be working now. I was able to home the printer... calibrate it the build plate and print from the sdcard now all while watching the g-code scroll through pronterface.

    Now to start learning to draw and print ourselves. Thanks for the help!

  4. #4
    Join Date
    Jul 2017
    Ahh, that makes sense. Printers usually move down until they hit the switch, then move up a little and go down more slowly until the switch is pressed again. With an always on limit switch, it would only move up. Glad to hear it worked out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts