Close



Results 1 to 3 of 3
  1. #1
    Student CBPrints's Avatar
    Join Date
    Jun 2015
    Location
    Canada
    Posts
    10
    Add CBPrints on Thingiverse

    Marlin config error, can't figure this one out!!

    Hey guys!

    So I've managed to get alot of my firmware configured, however out of no where this error started popping up...the bold red underlined text.

    #define XYZ_CONSTS_FROM_CONFIG(type, array, CONFIG) \
    static const PROGMEM type array##_P[3] = \
    { X_##CONFIG, Y_##CONFIG, Z_##CONFIG }; \
    static inline type array(int axis) \
    { return pgm_read_any(&array##_P[axis]); }

    It's located in the marlin.main.cpp file.

    Any ideas?

    I changed the baudrate and then it started acting up and wont verify without this error.

    Thanks in advance!

  2. #2
    Super Moderator Roxy's Avatar
    Join Date
    Apr 2014
    Location
    Lone Star State
    Posts
    2,183
    If you fork a particular Release Candidate or branch... It is real easy for people to look at what you are seeing and offer a suggestion. What branch are you using right now? Is it Marlin or MarlinDev? Etc. Etc.

  3. #3
    Student CBPrints's Avatar
    Join Date
    Jun 2015
    Location
    Canada
    Posts
    10
    Add CBPrints on Thingiverse
    Quote Originally Posted by Roxy View Post
    If you fork a particular Release Candidate or branch... It is real easy for people to look at what you are seeing and offer a suggestion. What branch are you using right now? Is it Marlin or MarlinDev? Etc. Etc.
    Sorry I'm new to the Rep rap scene.

    I sent the command M115 through Repetier and its bringing back "Marlin V1;"

    I'm guessing this is version 1?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •