Close



Results 1 to 5 of 5
  1. #1

    heater pin numbers

    Hi, I was installing the e3d hotend with a new heater cartridge and thermocouple. I think I accidentally changed the pin number for #define HEATER_0_PIN. I have it set to 8 right now. is this correct? the hotend is not heating up right now. thermocouple is working fine and I checked the resistance on the cartridge came out to 6.7.

    Thanks

  2. #2
    Staff Engineer printbus's Avatar
    Join Date
    May 2014
    Location
    Highlands Ranch, Colorado USA
    Posts
    1,414
    Add printbus on Thingiverse
    Not sure what you have for hardware or firmware, but I believe the typical Marlin/RAMPS config is as follows:

    HEATER_BED_PIN 8
    HEATER_1_PIN 9
    HEATER_0_PIN 10

    It can be tricky to work through the #if #else #endif logic. Always check to make sure no more than one definition is assigned to any pin for your specified motherboard type.

  3. #3
    it is a rambo 1.2b board with marlin firmware. Forgot to include that in there.

  4. #4
    Staff Engineer printbus's Avatar
    Join Date
    May 2014
    Location
    Highlands Ranch, Colorado USA
    Posts
    1,414
    Add printbus on Thingiverse
    Quote Originally Posted by ohms View Post
    it is a rambo 1.2b board with marlin firmware. Forgot to include that in there.
    Then I believe the mapping should be as follows:

    HEATER_BED_PIN 3
    HEATER_1_PIN 7
    HEATER_0_PIN 9

  5. #5
    ahh pin 9 did the trick. Thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •