Close



Results 1 to 5 of 5
  1. #1
    Engineer-in-Training
    Join Date
    Jan 2016
    Posts
    236

    Flashforge Creator Pro driver for Windows 7 Pro?

    The woodworking shop at the program for mentally-handicapped people where I work got a new Flashforge Creator Pro 3D printer (the new one with one-piece top cover). I tried to install the driver for the printer on an HP Z220 computer running Windows 7 Pro but I got a yellow "!" in the driver under device manager. How can I fix this problem? I tried to level the build platform using the LCD control panel but I couldn't do it. How can I do this? I tried to level the build platform using a file from the SD card but after adjusting the leveling screws so that the paper can be moved with a little drag and the nozzles move to the center of the build platform, the paper can be moved without any drag. How can I fix this? There is blue tape on the build platform and the printed job didn't stick to the tape. I couldn't remove the spool from the holder to see if the filament is ABS or PLA. The printer came with Flashprint and ReplicatorG. Which program to use? I could use Simplify3D but I already have it at home for my own PowerSpec Ultra printer. Are there any differences between Flashforge Creator Pro and PowerSpec 3D Pro 2?

  2. #2
    Super Moderator curious aardvark's Avatar
    Join Date
    Jul 2014
    Posts
    5,196
    well flashprint should include the driver. Actually thinking about it, the only software I've used that installs a driver is makerware desktop.

    Pretty sure simplify3d didn't.
    What you want - I think, are the python files from here: http://www.flashforge-usa.com/support/downloads/

    The printer identifies itself i device manager under Ports as: mightyboard, s3g via serial.
    Well my creator does anyway.
    Thinking back, I did install rep-g, for about an hour. But I'm pretty sure it was the makerware bundle that had the actual drivers and python install routines.
    Try this: http://3dprintboard.com/showthread.p...Download-(x64)

    Hp pretty much only use 64 bit windows 7 - so you should be fine on that score.
    Hope that works for you.

  3. #3
    Technologist
    Join Date
    Apr 2016
    Posts
    114
    Not sure about the drivers, but the bed leveling sounds like a slightly bowed plated - or sag in the extruder carriage.

    Once you have lined up the bed, go an extra 1/4 turn on all 4 screws. This will increase the drag on the edges and tighten up the centre a little as well.

    If PLA, get a glue stick and apply an even layer all over the blue tape. If it's ABS, then I would recommend a different surface - Kapton with Acetone slurry or Buildtak - which won't need any further preperation.

    I would suggest you just run with PLA, as it is easier to get to stick and does not smell as strong while printing.

  4. #4
    Super Moderator
    Join Date
    Apr 2014
    Location
    KS
    Posts
    908
    Add jfkansas on Thingiverse
    First this isn't a desktop inkjet printer. There is really almost never a need to connect directly to a computer. It is actually recommended to not keep connected.

    There is only a few cosmetic differences between the FlashForge and the Powerspec.

    You shouldn't use a leveling program on the SD card. There is a script accessible from the front panel to do this. The best way to level is to manually move the gantry so the nozzle is over the 3 leveling spots. Never level to the middle of the build plate, it will always be slightly closer due to the sag in the gantry. Some thing the build plate is warped and that is rarely the case if ever.


    Quote Originally Posted by jeffmorris View Post
    The woodworking shop at the program for mentally-handicapped people where I work got a new Flashforge Creator Pro 3D printer (the new one with one-piece top cover). I tried to install the driver for the printer on an HP Z220 computer running Windows 7 Pro but I got a yellow "!" in the driver under device manager. How can I fix this problem? I tried to level the build platform using the LCD control panel but I couldn't do it. How can I do this? I tried to level the build platform using a file from the SD card but after adjusting the leveling screws so that the paper can be moved with a little drag and the nozzles move to the center of the build platform, the paper can be moved without any drag. How can I fix this? There is blue tape on the build platform and the printed job didn't stick to the tape. I couldn't remove the spool from the holder to see if the filament is ABS or PLA. The printer came with Flashprint and ReplicatorG. Which program to use? I could use Simplify3D but I already have it at home for my own PowerSpec Ultra printer. Are there any differences between Flashforge Creator Pro and PowerSpec 3D Pro 2?

  5. #5
    Super Moderator
    Join Date
    Jun 2016
    Location
    Oklahoma
    Posts
    903
    If you are getting a "conflict" with the driver it is probably a port conflict with something else attached to the computer.

    Flashprint only connects to the printer to update firmaware not to print. You have to save the file to a SD card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •