Close



Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 55
  1. #31
    Engineer-in-Training
    Join Date
    Jul 2016
    Location
    Pennsylvania, USA
    Posts
    255
    Quote Originally Posted by Roxy View Post
    Grab RCBugFix. You just turn on the #define BLTOUCH option and everything works....
    Hi

    Ok, here's what I did:

    Grab RCBugFix, define the display (RepRap Discount Smart Graphical), upload the code to the Ramps.

    Reset Ramps

    There is no graphic on the display for the heated bed

    Try to set bed heat ... no go (from serial, or from sub menus).

    Try to run PID tune on the bed ... thermal runaway, glass bed shatters into many pieces. Why did I try that? Terminal stupidity is my only excuse

    ===

    Repeat with everything in sight. I only get a bed heat graphic when the screen reads " UBL6 FT-2020 ready." All the other new branches have the issue with the bed heat on my machine.

    I'll pound on it some more this evening. Firmware usually works best after you have a few beers and yell at it a lot ....


    Bob

  2. #32
    Super Moderator Roxy's Avatar
    Join Date
    Apr 2014
    Location
    Lone Star State
    Posts
    2,070
    devel_ubl was forked from RCBugFix on July 4th. The BLTouch stuff is not in devel_ubl yet. (And that message "UBL6 FT-2020 ready." is from the UBL code base)

  3. #33
    Engineer-in-Training
    Join Date
    Jul 2016
    Location
    Pennsylvania, USA
    Posts
    255
    Hi

    After a bit of "quality time" digging through the code ... errrr .... during the day ... I have a few ideas what may be going wrong. The working code is indeed the UBL code branch. I was looking at it mainly to see what did and did not work in terms of the bed heat issue.

    =====

    So, yup, pilot error. The bed thermistor defaults to zero in the "normal" branches. It defaults to something rational in the UBL branch. I was compiling it and looking at it *before* digging into the thermistor tables. Obviously not the best approach !!!


    Bob
    Last edited by uncle_bob; 11-15-2016 at 05:05 PM.

  4. #34
    Super Moderator Roxy's Avatar
    Join Date
    Apr 2014
    Location
    Lone Star State
    Posts
    2,070
    And just so you know... The Configuration.h file from the UBL branch is different than the default Configuration.h file from the RC-7 and RCBugFix branch.

    The reason they are different is UBL is considered a 'Development' branch. The Configuration.h file in the UBL code is very literally my Configuration.h file. I know it works (at least on my hardware). And the theory is, if a user starts with that file and makes the minimum number of changes to accommodate their machine, they have the best chance of the code base still working for them.

    It may be time to go back to the standard and default Configuration.h file in the UBL code. Things pretty much work. (at least on Cartesian Printers. Delta's still have not been brought up on that code base yet.)

  5. #35
    Engineer-in-Training
    Join Date
    Jul 2016
    Location
    Pennsylvania, USA
    Posts
    255
    Hi

    I would certainly encourage folding UBL back into the main branch. I have a cartesian printer so that may bias my recommendation.

    Bob

  6. #36
    Engineer-in-Training
    Join Date
    Jul 2014
    Posts
    307
    Quote Originally Posted by Roxy View Post
    And just so you know... The Configuration.h file from the UBL branch is different than the default Configuration.h file from the RC-7 and RCBugFix branch.

    The reason they are different is UBL is considered a 'Development' branch. The Configuration.h file in the UBL code is very literally my Configuration.h file. I know it works (at least on my hardware). And the theory is, if a user starts with that file and makes the minimum number of changes to accommodate their machine, they have the best chance of the code base still working for them.

    It may be time to go back to the standard and default Configuration.h file in the UBL code. Things pretty much work. (at least on Cartesian Printers. Delta's still have not been brought up on that code base yet.)
    Roxy, I have a silly question for you. My Printers are now running the RC8 Marlin 1.1 RCbugfix, from Dec 2016.

    I see the #define bltouch, do I just have to uncomment that and update the spacing from the nozzle? Or do I also have to play with my starting G-Code as long as uncomment the BL Touch?
    Last edited by BLKKROW; 01-21-2017 at 11:17 PM.

  7. #37
    Super Moderator Roxy's Avatar
    Join Date
    Apr 2014
    Location
    Lone Star State
    Posts
    2,070
    Quote Originally Posted by uncle_bob View Post
    Hi

    I would certainly encourage folding UBL back into the main branch. I have a cartesian printer so that may bias my recommendation.

    Bob
    This hasn't been discussed lately (in the last few months). But the plan was to get RC8 promoted to 'Stable' and then no more features would be added to it. Only bug fixes. And at that time, the plan was to then make the UBL branch the main Development Branch and use that to absorb any new features to the code base. Eventually... (maybe in 6 months???) it would start a Release Candidate phase and that would ultimately result in a new 'Stable' branch.

    The big problem with 'folding' UBL back into the main branch is the other bed leveling schemes would disappear. UBL pretty replaces the existing code and feature set. So it is probably less controversial to just let it evolve on its own until there is no argument that it handles every case.

  8. #38
    I just ordered a BLTouch, for use with my 10" Pegasus. I've got a Titan extruder and a blower fan, and I cannot find one BLTouch mount that will work with my setup. It seems like every Titan mount has the BLTouch right where my fan would be. (Fan mount: http://www.thingiverse.com/thing:2074787) Anyone have recommendations for a mount that I can add, or another compatible blower mount that includes BLTouch?

  9. #39
    Engineer-in-Training
    Join Date
    Jul 2016
    Location
    Pennsylvania, USA
    Posts
    255
    Hi

    I simply redesigned the whole extruder and X carriage from scratch ....

    Bob

  10. #40
    I've been struggling to get my BLtouch to work on my 10" Pegasus. Anyone have a config I can use?

Page 4 of 6 FirstFirst ... 23456 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •