Close



Results 1 to 9 of 9
  1. #1

    CTC printer dual extruder DOA

    hi, i'm gonna introduce myself first. I'm an IT tecnician from italy.
    I bought a couple of days a CTC bizer II from ebay, set that up checked and tightned all the screws that needed to and started printing.
    The first print went well, very well actually. At the second print it stopped @80% the lcd started blinking and everything stopped. Printed via SD.
    Shut the sistem down removed usb and Sd turned back on. I hear a buzz and lcd is blinking showing nothing.
    So i carefully turned the machine upside down to inspect led code on mobo, the PSU has green light on, only 24v red led lights up right now. At first all the 3 volt leds were on and overheating led was on when the problem had already occurred.
    I emailed the reseller, i emailed CTC support and i tried 3 hubs, i started printing on saturday afteroon and on sunday morning printer was dead!
    I would like to fix this asap(currently not at work so have time to spend on working with the new toy)but as usual reseller answer very slowly.
    Any1 has a clue about this?the only thing i did not inspect is the inside of the psu, again green light is on, but since it's brand new it would brake warranty i guess.
    BR and appreciation to any1 who can help

  2. #2
    The seller asked me this morning if i wanted a new mainboard for replacement..i told him that i am actually no ctc tecnician and unable to identify the problem. If he thinks board is the problem then yes! Suggestions?

  3. #3
    Have you checked what all the voltage rails are reading? Could be a fault on the PSU rather than the mother board. If you are an IT technician, maybe you can find a PSU with the same voltage rails.

  4. #4
    Technologist 3dex ltd's Avatar
    Join Date
    Dec 2015
    Location
    United Kingdom
    Posts
    148
    Follow 3dex ltd On Twitter Add 3dex ltd on Facebook
    Yeah I would also suggest checking out the PSU.

    Welcome to the forum By the way. You've come to the right place as this forum is full of people with great advice.

  5. #5
    Hi, first of all ty for you for your replies. Since it's brand new(received on friday)and it's my first printer i'm still getting acquaintance with the machine. I suppose it's PSU since it randomly gets the 24V the 3,3 and 5 V on.
    Even though the fan spins sometimes very slowly, sometimes not at all i hear a buzz that usually on ATX psu's meant:"hey i0m going to die!"
    to be sure i asked the ebay reseller printchainstore to send me both parts, we'll see when they arrive.
    Just in case do you knwo where to buy a spare psu for replacement?

    Moderator note: Late posting is due to unexpected delay in obtaining moderator approval.
    Last edited by printbus; 09-16-2016 at 07:17 PM.

  6. #6
    Iaske the seller printchain store to send me both mainboard and psu just to be sure. just in case does any1 know where to buy a spare psu?

    Moderator note: Late posting is due to unexpected delay in obtaining moderator approval.
    Last edited by printbus; 09-16-2016 at 07:17 PM.

  7. #7
    I'm making the vendor printchain from ebay send both mainboard and psu. Anywhere i can find spare parts for the printer?

    Moderator note: Late posting is due to unexpected delay in obtaining moderator approval.
    Last edited by printbus; 09-16-2016 at 07:17 PM.

  8. #8
    Waiting for Psu and mainboard replacement

    Moderator note: Late posting is due to unexpected delay in obtaining moderator approval.
    Last edited by printbus; 09-16-2016 at 07:18 PM.

  9. #9
    Follow...
    928bet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •